aboutsummaryrefslogtreecommitdiffstats
path: root/community/ndctl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ndctl/APKBUILD')
-rw-r--r--community/ndctl/APKBUILD75
1 files changed, 39 insertions, 36 deletions
diff --git a/community/ndctl/APKBUILD b/community/ndctl/APKBUILD
index bdc48e1c049..a327075af19 100644
--- a/community/ndctl/APKBUILD
+++ b/community/ndctl/APKBUILD
@@ -1,51 +1,54 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Breno Leitao <breno.leitao@gmail.com>
-# Maintainer:
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=ndctl
-pkgver=71.1
+pkgver=78
pkgrel=1
pkgdesc="Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel"
url="https://github.com/pmem/ndctl"
arch="all"
-license="GPL-2.0-only LGPL-2.1-only"
-depends="libuuid json-c kmod"
-makedepends="autoconf automake libtool asciidoc xmlto kmod-dev
- eudev-dev util-linux-dev json-c-dev linux-headers asciidoctor
- bash-completion keyutils-dev"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-libs
- $pkgname-bash-completion:bashcomp:noarch"
-source="ndctl-$pkgver.tar.gz::https://github.com/pmem/ndctl/archive/v$pkgver.tar.gz"
+license="GPL-2.0-only AND LGPL-2.1-only"
+depends="kmod"
+makedepends="
+ asciidoc
+ asciidoctor
+ bash-completion-dev
+ eudev-dev
+ iniparser-dev
+ json-c-dev
+ keyutils-dev
+ kmod-dev
+ libtraceevent-dev
+ libtracefs-dev
+ linux-headers
+ meson
+ util-linux-dev
+ "
+subpackages="
+ $pkgname-doc
+ $pkgname-dev
+ $pkgname-libs
+ $pkgname-bash-completion
+ "
+source="ndctl-$pkgver.tar.gz::https://github.com/pmem/ndctl/archive/v$pkgver.tar.gz
+ no-bash.patch
+ "
options="!check" # tests require building & loading the nfit_test.ko kernel module
-prepare() {
- default_prepare
- echo $pkgver >"$builddir/version"
- ./autogen.sh
-}
-
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --without-systemd
- make
+ abuild-meson \
+ -Db_lto=true \
+ -Dsystemd=disabled \
+ -Dversion-tag="$pkgver" \
+ . output
+ meson compile -C output
}
package() {
- make DESTDIR="$pkgdir" install
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completion for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="92fb06ca64455775ce0b89ba0846f70235e02fe3502e2a8a55a858f76f87cb90ae98f5bf01620e5884f667ea78ee2bee2cd9e7a85ffa8f8d9c456e9282ca9ebc ndctl-71.1.tar.gz"
+sha512sums="
+ad217dd45c8d6bbd0089a88c46e1e04813b65e97c8817aaddeca967b20ce948e76c4b7ede5517c45d0b645b5c3dc61aac95cc944e8e5fc60100e45b41f13f2a0 ndctl-78.tar.gz
+cb48fdf9ff293164bf0ef52f38194d4bfb56eeec3f4cd173f4d3dd545ab17dcaeeb0362a3df700b519dc2c97407664094363faf76b900135eb24fed1ae4519fa no-bash.patch
+"