aboutsummaryrefslogtreecommitdiffstats
path: root/community/ndctl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ndctl/APKBUILD')
-rw-r--r--community/ndctl/APKBUILD71
1 files changed, 36 insertions, 35 deletions
diff --git a/community/ndctl/APKBUILD b/community/ndctl/APKBUILD
index b1891517b48..a327075af19 100644
--- a/community/ndctl/APKBUILD
+++ b/community/ndctl/APKBUILD
@@ -1,53 +1,54 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Breno Leitao <breno.leitao@gmail.com>
-# Maintainer:
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=ndctl
-pkgver=72.1
-pkgrel=0
+pkgver=78
+pkgrel=1
pkgdesc="Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel"
url="https://github.com/pmem/ndctl"
arch="all"
license="GPL-2.0-only AND LGPL-2.1-only"
depends="kmod"
-makedepends="asciidoc asciidoctor autoconf automake bash-completion
- eudev-dev iniparser-dev json-c-dev keyutils-dev kmod-dev libtool
- linux-headers util-linux-dev xmlto"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-libs
- $pkgname-bash-completion:bashcomp:noarch"
-source="ndctl-$pkgver.tar.gz::https://github.com/pmem/ndctl/archive/v$pkgver.tar.gz"
+makedepends="
+ asciidoc
+ asciidoctor
+ bash-completion-dev
+ eudev-dev
+ iniparser-dev
+ json-c-dev
+ keyutils-dev
+ kmod-dev
+ libtraceevent-dev
+ libtracefs-dev
+ linux-headers
+ meson
+ util-linux-dev
+ "
+subpackages="
+ $pkgname-doc
+ $pkgname-dev
+ $pkgname-libs
+ $pkgname-bash-completion
+ "
+source="ndctl-$pkgver.tar.gz::https://github.com/pmem/ndctl/archive/v$pkgver.tar.gz
+ no-bash.patch
+ "
options="!check" # tests require building & loading the nfit_test.ko kernel module
-prepare() {
- default_prepare
- echo $pkgver >"$builddir/version"
- ./autogen.sh
-}
-
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --without-systemd
- make
+ abuild-meson \
+ -Db_lto=true \
+ -Dsystemd=disabled \
+ -Dversion-tag="$pkgver" \
+ . output
+ meson compile -C output
}
package() {
- make DESTDIR="$pkgdir" install
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completion for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
-7304e23121c99457fa6e22a399fb636f6a66d6d07b090463ec41e424687b06e7e8a1a18623ab9dd5783aaccfa09ff964e3477b63aaa4614ac60f6e6050452f12 ndctl-72.1.tar.gz
+ad217dd45c8d6bbd0089a88c46e1e04813b65e97c8817aaddeca967b20ce948e76c4b7ede5517c45d0b645b5c3dc61aac95cc944e8e5fc60100e45b41f13f2a0 ndctl-78.tar.gz
+cb48fdf9ff293164bf0ef52f38194d4bfb56eeec3f4cd173f4d3dd545ab17dcaeeb0362a3df700b519dc2c97407664094363faf76b900135eb24fed1ae4519fa no-bash.patch
"