aboutsummaryrefslogtreecommitdiffstats
path: root/community/nemo-qml-plugin-models/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nemo-qml-plugin-models/APKBUILD')
-rw-r--r--community/nemo-qml-plugin-models/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/nemo-qml-plugin-models/APKBUILD b/community/nemo-qml-plugin-models/APKBUILD
new file mode 100644
index 00000000000..e968dfe9fb0
--- /dev/null
+++ b/community/nemo-qml-plugin-models/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=nemo-qml-plugin-models
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="Nemo QML models plugin"
+url="https://git.sailfishos.org/mer-core/nemo-qml-plugin-models"
+arch="all"
+license="BSD-3-Clause"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev libmlocale-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev"
+source="https://git.sailfishos.org/mer-core/nemo-qml-plugin-models/-/archive/$pkgver/nemo-qml-plugin-models-$pkgver.tar.gz"
+options="!check" # No suitable tests
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+
+ # Remove tests
+ rm -rf "$pkgdir"/opt
+}
+
+sha512sums="bdc41c7e4d3043bab06137cd29a2fe363d13eed1a617cc04f2be82eebfab62e34b01cd0655cfb7a616ea08705ed3ede979a60d3ebc13fc14c74352de3142400a nemo-qml-plugin-models-0.1.3.tar.gz"