aboutsummaryrefslogtreecommitdiffstats
path: root/community/nemo-qml-plugin-systemsettings/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nemo-qml-plugin-systemsettings/APKBUILD')
-rw-r--r--community/nemo-qml-plugin-systemsettings/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/community/nemo-qml-plugin-systemsettings/APKBUILD b/community/nemo-qml-plugin-systemsettings/APKBUILD
index 0400f54c7c4..db2f456f969 100644
--- a/community/nemo-qml-plugin-systemsettings/APKBUILD
+++ b/community/nemo-qml-plugin-systemsettings/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nemo-qml-plugin-systemsettings
-pkgver=0.5.75
-pkgrel=0
+pkgver=0.5.82
+pkgrel=3
pkgdesc="Nemo QML systemsettings plugin"
-url="https://git.sailfishos.org/mer-core/nemo-qml-plugin-systemsettings"
+url="https://github.com/sailfishos/nemo-qml-plugin-systemsettings"
arch="all !armhf" # missing dependencies
license="BSD-3-Clause"
depends_dev="
@@ -12,6 +12,7 @@ depends_dev="
mce-dev
mlite-dev
nemo-qml-plugin-dbus-dev
+ openssl-dev>3
qt5-qtdeclarative-dev
qt5-qtsystems-dev
sailfish-access-control
@@ -27,13 +28,13 @@ makedepends="$depends_dev
qt5-qtbase-dev
qt5-qttools-dev
qt5-qtxmlpatterns-dev
- qtchooser
"
subpackages="$pkgname-dev"
-source="https://git.sailfishos.org/mer-core/nemo-qml-plugin-systemsettings/-/archive/$pkgver/nemo-qml-plugin-systemsettings-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/sailfishos/nemo-qml-plugin-systemsettings/archive/$pkgver.tar.gz
0001-Remove-developer-mode.patch
0002-Remove-packagekit-usage.patch
0003-Include-linux-quota.h.patch
+ 0004-Fix-musl-lfs64.patch
"
build() {
@@ -43,9 +44,15 @@ build() {
package() {
INSTALL_ROOT="$pkgdir" make install
+
+ # Remove installed tests
+ rm -r "$pkgdir"/opt
}
-sha512sums="849736bf153510b1ffa06f4406abea4ecae469dec23e93b071848232e5fdcfe9366b460b40e62238fb167a15d6a0c42c6c52a34314e6142fb6fff666da35e67b nemo-qml-plugin-systemsettings-0.5.75.tar.gz
+sha512sums="
+566e4556f13a3b8ca3da3bcbd9fcef2354f5f2d854feb161f0bbfea683d651c6faf36c41ed43c4f246ba6e96d48c1f1e24551f111a896b21453c01b4753f7d8f nemo-qml-plugin-systemsettings-0.5.82.tar.gz
4a34709e3a3fa14e53a79d767d5bd442aecdda8c67f54d6a6546fa792385043c1aaf3cf3f68ef6bc099cb354bb1503d3653ed974d5a9db7ab7e62591916ee933 0001-Remove-developer-mode.patch
e00c3d0ccaf9ceffbd4006c008bbd71c286998590640830c0f8997e0f292f40bc5837b57070701170198a645b756cfb87e74cc570b8554aba6f7c1ade5276a2a 0002-Remove-packagekit-usage.patch
-561741fb4f83656ac5d26e979033991347280e6e90f0ef0dc043318fdaf62f136673039dfac1b1af2bf94322f761525725d43aa2d345b7a8599d992f150800ae 0003-Include-linux-quota.h.patch"
+561741fb4f83656ac5d26e979033991347280e6e90f0ef0dc043318fdaf62f136673039dfac1b1af2bf94322f761525725d43aa2d345b7a8599d992f150800ae 0003-Include-linux-quota.h.patch
+4aafdc5788eb78625f754ec6a30c5520d265d0c52632175ddf78d5f127aef0c62d060347bc1e490881e2552417ba90717672157bdae4e40c3328ecff0def090d 0004-Fix-musl-lfs64.patch
+"