aboutsummaryrefslogtreecommitdiffstats
path: root/community/nemo-qml-plugin-time/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nemo-qml-plugin-time/APKBUILD')
-rw-r--r--community/nemo-qml-plugin-time/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/nemo-qml-plugin-time/APKBUILD b/community/nemo-qml-plugin-time/APKBUILD
new file mode 100644
index 00000000000..ce97b144ef2
--- /dev/null
+++ b/community/nemo-qml-plugin-time/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=nemo-qml-plugin-time
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="Nemo QML time plugin"
+url="https://github.com/sailfishos/nemo-qml-plugin-time"
+arch="all"
+license="BSD-3-Clause"
+makedepends="
+ mce-dev
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ timed-dev
+ "
+source="https://github.com/sailfishos/nemo-qml-plugin-time/archive/$pkgver/nemo-qml-plugin-time-$pkgver.tar.gz"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+
+ # Remove installed tests
+ rm -r "$pkgdir"/opt
+}
+
+sha512sums="
+b8a689b026efa5a8b455ad0ee75be90dcf71f3567a5f2cdac7939e668dbbc19af23363349fe35fb440ab8b2a5b944b794f40a4025a90cd8f3174d19ed218b966 nemo-qml-plugin-time-0.1.5.tar.gz
+"