aboutsummaryrefslogtreecommitdiffstats
path: root/community/nemo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nemo/APKBUILD')
-rw-r--r--community/nemo/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/nemo/APKBUILD b/community/nemo/APKBUILD
index 6d795adaadb..5641e53d027 100644
--- a/community/nemo/APKBUILD
+++ b/community/nemo/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
-# Maintainer: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Hugo Osvaldo Barrera <hugo@whynothugo.nl>
pkgname=nemo
-pkgver=4.8.6
+pkgver=6.0.2
pkgrel=0
pkgdesc="File manager for the Cinnamon desktop environment"
-# s390x, mips64 and ppc64le blocked by exempi
+# s390x and ppc64le blocked by exempi
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !mips64 !ppc64le !riscv64" # exempi, libexif-dev not available for all archs
+arch="all !s390x !ppc64le !riscv64" # exempi, libexif-dev not available for all archs
url="https://github.com/linuxmint/nemo"
license="GPL-2.0-only"
+depends="desktop-file-utils"
makedepends="
- exempi-dev
- xapp-dev
cinnamon-desktop-dev
dconf-dev
+ exempi-dev
gobject-introspection-dev
gvfs-dev
intltool
libexif-dev
+ libgsf-dev
libnotify-dev
libxml2-dev
meson
- python3"
+ python3
+ xapp-dev
+ "
checkdepends="xvfb-run"
source="https://github.com/linuxmint/nemo/archive/$pkgver/nemo-$pkgver.tar.gz"
subpackages="$pkgname-doc $pkgname-dev"
@@ -29,7 +32,7 @@ options="!check" # tests are broken: https://github.com/linuxmint/nemo/issues/25
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
@@ -39,4 +42,6 @@ package() {
check() {
xvfb-run meson test -C output
}
-sha512sums="fd34dd7dc78ad8799ba3f4d07f4e71c91cc4edf392781ed7d3c4d693cc7bdd77e83e4307ba90986af8dd5640b4bd062578cc5d8628c4307eec8bdffd66cb3099 nemo-4.8.6.tar.gz"
+sha512sums="
+05e8a6ab785f527ad61c1fe57d372ae8ea8f77d27ec8608d38e99f5f0f9065aecef4b84d1b016b682d14320d7099806d5672a101c0a370429d1c3f2a341fed1c nemo-6.0.2.tar.gz
+"