aboutsummaryrefslogtreecommitdiffstats
path: root/community/neovim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/neovim/APKBUILD')
-rw-r--r--community/neovim/APKBUILD66
1 files changed, 41 insertions, 25 deletions
diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index 4dcb0cc7088..c6d8922e4d8 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -1,58 +1,74 @@
# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
#
-# secfixes:
-# 0.3.6-r0:
-# - CVE-2019-12735
-# 0.2.0-r0:
-# - CVE-2017-5953
-# - CVE-2017-6349
-# - CVE-2017-6350
-# 0.1.6-r1:
-# - CVE-2016-1248
-
# TODO: Try to trim the base package to include only common syntax files etc.
pkgname=neovim
-pkgver=0.6.0
+pkgver=0.9.5
pkgrel=0
pkgdesc="Vim-fork focused on extensibility and agility"
-url="https://neovim.io"
-# riscv64 blocked by luajit -> libluv
-arch="all !riscv64"
+url="https://neovim.io/"
+arch="all"
license="Apache-2.0 AND Vim"
-makedepends="cmake gettext-dev gperf libtermkey-dev libuv-dev libvterm-dev
- lua5.1-lpeg lua5.1-mpack msgpack-c-dev unibilium-dev libluv-dev
- tree-sitter-dev"
+makedepends="
+ cmake
+ gettext-dev
+ gperf
+ libtermkey-dev
+ libuv-dev
+ libvterm-dev
+ lua-luv-dev
+ lua5.1-lpeg
+ lua5.1-mpack
+ msgpack-c-dev
+ samurai
+ tree-sitter-dev
+ unibilium-dev
+ "
# Build neovim with lua instead of luajit on s390x
# See https://github.com/neovim/neovim/issues/7879
case "$CARCH" in
- s390x) makedepends="$makedepends lua5.1-dev lua5.1-bitop" ;;
+ ppc64le | riscv64 | s390x) makedepends="$makedepends lua5.1-dev lua5.1-bitop" ;;
*) makedepends="$makedepends luajit-dev" ;;
esac
subpackages="$pkgname-lang $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/neovim/archive/v$pkgver.tar.gz
+source="https://github.com/neovim/neovim/archive/v$pkgver/neovim-$pkgver.tar.gz
nodoc.txt
"
+# secfixes:
+# 0.3.6-r0:
+# - CVE-2019-12735
+# 0.2.0-r0:
+# - CVE-2017-5953
+# - CVE-2017-6349
+# - CVE-2017-6350
+# 0.1.6-r1:
+# - CVE-2016-1248
build() {
local cmakeoptions=
case "$CARCH" in
- s390x) cmakeoptions="-DPREFER_LUA=ON" ;;
+ ppc64le | riscv64 | s390x) cmakeoptions="-DPREFER_LUA=ON" ;;
esac
- # CMAKE_BUILD_TYPE - don't use "None", see #13039
- cmake -B build \
+ # DCI_BUILD: See https://github.com/neovim/neovim/issues/22932
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_JEMALLOC=FALSE \
+ -DENABLE_LTO=TRUE \
-DCMAKE_VERBOSE_MAKEFILE=TRUE \
+ -DCI_BUILD=OFF \
$cmakeoptions
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ # Tree-sitter grammars are packaged separately and installed into
+ # /usr/lib/tree-sitter.
+ ln -s ../../../lib/tree-sitter "$pkgdir"/usr/share/nvim/runtime/parser
}
doc() {
@@ -69,12 +85,12 @@ doc() {
# with information why docs are not available and how to install them.
install -D "$srcdir"/nodoc.txt \
"$pkgdir"/$docdir/nodoc.txt
- local f; for f in "$subpkgdir"/$docdir/*.txt; do
- ln -s nodoc.txt "$pkgdir"/$docdir/$(basename $f)
+ local f; for f in "$subpkgdir/$docdir"/*.txt; do
+ ln -s nodoc.txt "$pkgdir/$docdir/$(basename $f)"
done
}
sha512sums="
-c007d076fb89288fe0496fa243fc6f485b0b33120c96b0bf37d8fe6469c672eb641fefbc3f7262ec726e40910c44d37ff7efb1723c05ba920ff6ae512b1d43e6 neovim-0.6.0.tar.gz
+6e20d0a1d506dc292dd68dabe4b5635f86c019ca832f9927e907377e6d21fe7765b3010f5bba644bb2d7a76c178d55b290af24856a7e3c4083a1aa60bc496775 neovim-0.9.5.tar.gz
72ab288f53acddc088c567aafe8c5afa6835325fab7879e782d1d62f87a662f3a6bac123c450debbae1b32336cc60b2830b429838ee3dfcc7524773b5069f4f0 nodoc.txt
"