aboutsummaryrefslogtreecommitdiffstats
path: root/community/netifrc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/netifrc/APKBUILD')
-rw-r--r--community/netifrc/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/netifrc/APKBUILD b/community/netifrc/APKBUILD
new file mode 100644
index 00000000000..367b21a8a3b
--- /dev/null
+++ b/community/netifrc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
+# Maintainer: Haelwenn (lanodan) Monnier <contact+alpine@hacktivis.me>
+pkgname=netifrc
+pkgver=0.7.8
+pkgrel=0
+pkgdesc="Gentoo Network Interface Management Scripts"
+url="https://gitweb.gentoo.org/proj/netifrc.git/"
+arch="noarch"
+license="BSD-2-Clause"
+depends="udev"
+makedepends="eudev-dev"
+subpackages="$pkgname-openrc $pkgname-doc"
+source="https://gitweb.gentoo.org/proj/netifrc.git/snapshot/netifrc-$pkgver.tar.gz"
+
+build() {
+ make PREFIX=/usr SYSCONFDIR=/etc SBINDIR=/sbin all
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr SYSCONFDIR=/etc SBINDIR=/sbin install
+}
+
+check() {
+ make check
+}
+
+sha512sums="
+4aeee683f7a593609da111a16c5653c12d17459f102ac3f7fd3412071c0a01f664d3724864c08ebfe40124c2a379325a424f1d8624479c8558096d7349acfe6e netifrc-0.7.8.tar.gz
+"