aboutsummaryrefslogtreecommitdiffstats
path: root/community/newsflash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/newsflash/APKBUILD')
-rw-r--r--community/newsflash/APKBUILD31
1 files changed, 22 insertions, 9 deletions
diff --git a/community/newsflash/APKBUILD b/community/newsflash/APKBUILD
index ecbc6d7b820..11a0c137e84 100644
--- a/community/newsflash/APKBUILD
+++ b/community/newsflash/APKBUILD
@@ -1,27 +1,40 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=newsflash
-pkgver=1.5.1
+pkgver=3.2.0
pkgrel=0
pkgdesc="An rss feed reader that supports various web based services"
url="https://gitlab.com/news-flash/news_flash_gtk/"
-arch="all !s390x !mips64 !riscv64" # cargo, rust, libhandy not found
+# s390x: blueprint-compiler errors out in _resolve_dir_entry
+arch="all !s390x"
license="GPL-3.0-only"
-makedepends="meson bash rust cargo webkit2gtk-dev libhandy1-dev sqlite-dev gettext-dev openssl1.1-compat-dev"
-source="news_flash_gtk-v.$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/$pkgver/news_flash_gtk-$pkgver.tar.gz"
-options="!check" # no tests
-builddir="$srcdir/news_flash_gtk-$pkgver"
+depends="desktop-file-utils"
+makedepends="
+ bash
+ blueprint-compiler
+ cargo
+ gettext-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ webkit2gtk-6.0-dev
+ "
+subpackages="$pkgname-lang"
+source="https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz"
+options="net !check" # no tests
+builddir="$srcdir/news_flash_gtk-v.$pkgver"
build() {
- export RUSTC_BOOTSTRAP=obfstr
abuild-meson . output
- meson compile -j 2 -C output
+ meson compile -j 1 -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ ln -s io.gitlab.news_flash.NewsFlash "$pkgdir"/usr/bin/newsflash
}
sha512sums="
-b15e12567c585281474a6a09dbeb83dd860ee626b140d0194aeb311b0cfe3e3dad2c92ffa89f2f76b18bb2f230875910834041b3dc18ca3199b5ad4913886e5d news_flash_gtk-v.1.5.1.tar.gz
+f4d68b431f42784b6cb161dbf363e3adab0bc28e0acf341d28c94b842c84417f254bd487ddf63165f14efb520f741f41357b2d287a2c2061d17a1ebb61ec05c3 news_flash_gtk-v.3.2.0.tar.gz
"