aboutsummaryrefslogtreecommitdiffstats
path: root/community/newsflash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/newsflash/APKBUILD')
-rw-r--r--community/newsflash/APKBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/community/newsflash/APKBUILD b/community/newsflash/APKBUILD
index 6366278f020..11a0c137e84 100644
--- a/community/newsflash/APKBUILD
+++ b/community/newsflash/APKBUILD
@@ -1,25 +1,40 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=newsflash
-pkgver=1.1.1
+pkgver=3.2.0
pkgrel=0
pkgdesc="An rss feed reader that supports various web based services"
url="https://gitlab.com/news-flash/news_flash_gtk/"
-arch="all !s390x !mips64 !riscv64" # cargo, rust, libhandy not found
+# s390x: blueprint-compiler errors out in _resolve_dir_entry
+arch="all !s390x"
license="GPL-3.0-only"
-makedepends="meson bash rust cargo webkit2gtk-dev libhandy1-dev sqlite-dev gettext-dev openssl-dev"
-source="newsflash-$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/$pkgver/news_flash_gtk-$pkgver.tar.gz"
-options="!check" # no tests
-builddir="$srcdir/news_flash_gtk-$pkgver"
+depends="desktop-file-utils"
+makedepends="
+ bash
+ blueprint-compiler
+ cargo
+ gettext-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ webkit2gtk-6.0-dev
+ "
+subpackages="$pkgname-lang"
+source="https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz"
+options="net !check" # no tests
+builddir="$srcdir/news_flash_gtk-v.$pkgver"
build() {
- export RUSTC_BOOTSTRAP=obfstr
abuild-meson . output
- meson compile -j 2 -C output
+ meson compile -j 1 -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ ln -s io.gitlab.news_flash.NewsFlash "$pkgdir"/usr/bin/newsflash
}
-sha512sums="b003aefb133a22a56ea1abac01035cc405542ddb062a0018f698ff295fceb11091681c8568c282021c1828ac4ef5e439e14d1b538b0b279de4c12af6edeee40a newsflash-1.1.1.tar.gz"
+sha512sums="
+f4d68b431f42784b6cb161dbf363e3adab0bc28e0acf341d28c94b842c84417f254bd487ddf63165f14efb520f741f41357b2d287a2c2061d17a1ebb61ec05c3 news_flash_gtk-v.3.2.0.tar.gz
+"