aboutsummaryrefslogtreecommitdiffstats
path: root/community/newsflash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/newsflash/APKBUILD')
-rw-r--r--community/newsflash/APKBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/community/newsflash/APKBUILD b/community/newsflash/APKBUILD
index 3a828ec2a64..11a0c137e84 100644
--- a/community/newsflash/APKBUILD
+++ b/community/newsflash/APKBUILD
@@ -1,30 +1,40 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=newsflash
-pkgver=1.4.3
-pkgrel=2
+pkgver=3.2.0
+pkgrel=0
pkgdesc="An rss feed reader that supports various web based services"
url="https://gitlab.com/news-flash/news_flash_gtk/"
-arch="all !s390x !mips64 !riscv64" # cargo, rust, libhandy not found
+# s390x: blueprint-compiler errors out in _resolve_dir_entry
+arch="all !s390x"
license="GPL-3.0-only"
-makedepends="meson bash rust cargo webkit2gtk-dev libhandy1-dev sqlite-dev gettext-dev openssl1.1-compat-dev"
-source="news_flash_gtk-v.$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz
- 0001-Cargo.lock-Bump-the-newsblur-API-crate.patch
+depends="desktop-file-utils"
+makedepends="
+ bash
+ blueprint-compiler
+ cargo
+ gettext-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ webkit2gtk-6.0-dev
"
-options="!check" # no tests
+subpackages="$pkgname-lang"
+source="https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz"
+options="net !check" # no tests
builddir="$srcdir/news_flash_gtk-v.$pkgver"
build() {
- export RUSTC_BOOTSTRAP=obfstr
abuild-meson . output
- meson compile -j 2 -C output
+ meson compile -j 1 -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ ln -s io.gitlab.news_flash.NewsFlash "$pkgdir"/usr/bin/newsflash
}
sha512sums="
-d5048644563d0afbb273422c2316148c97e05e20b4f1aaab71206fb34e13b31cadf268752fbe09036ae8c0cb7d80ce36a4748d114d35047249daf92cfa641df3 news_flash_gtk-v.1.4.3.tar.gz
-444b77082d44d5c710d19d752dfd885442cc85c5f1bf3eda2280baed8b0937b1e2175433db93b3b6ce741f94fd71cf8f5ed265852813a0b446bebff51f8c5fc1 0001-Cargo.lock-Bump-the-newsblur-API-crate.patch
+f4d68b431f42784b6cb161dbf363e3adab0bc28e0acf341d28c94b842c84417f254bd487ddf63165f14efb520f741f41357b2d287a2c2061d17a1ebb61ec05c3 news_flash_gtk-v.3.2.0.tar.gz
"