aboutsummaryrefslogtreecommitdiffstats
path: root/community/nfpm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nfpm/APKBUILD')
-rw-r--r--community/nfpm/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/nfpm/APKBUILD b/community/nfpm/APKBUILD
index bab42acfff2..8592092175d 100644
--- a/community/nfpm/APKBUILD
+++ b/community/nfpm/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=nfpm
-pkgver=2.16.0
-pkgrel=0
+pkgver=2.36.1
+pkgrel=1
pkgdesc="a simple apk, Deb and RPM packager without external dependencies"
url="https://nfpm.goreleaser.com/"
arch="all !riscv64"
@@ -10,11 +10,17 @@ license="MIT"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/goreleaser/nfpm/archive/v$pkgver.tar.gz"
-export GOMODCACHE="$srcdir/go"
+# secfixes:
+# 2.35.2-r0:
+# - CVE-2023-49568
+
export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -ldflags "-s -w -X main.version=$pkgver" -v -o nfpm ./cmd/nfpm/main.go
+ go build -ldflags "-X main.version=$pkgver" -v -o nfpm ./cmd/nfpm/main.go
}
check() {
@@ -26,5 +32,5 @@ package() {
}
sha512sums="
-de8e73329f5b16b7642201ad5d1d371c5b9676e21d432639c992f79a1b1285e6004d20ce8bbc1c6262c16b9b068444ad4d146fe3776266cbd4f42eae848d7534 nfpm-2.16.0.tar.gz
+233f6c7cc27906728755b06a755e09c5a89fff0ffcf0eb32517d32b5f8799722a18c5d398e5cc35523c1a4ad406c84d2d9c1dad2846d25fa27e58ce0842d5494 nfpm-2.36.1.tar.gz
"