aboutsummaryrefslogtreecommitdiffstats
path: root/community/nimble/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nimble/APKBUILD')
-rw-r--r--community/nimble/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/nimble/APKBUILD b/community/nimble/APKBUILD
index 47b30976a87..ee05aeb2b8a 100644
--- a/community/nimble/APKBUILD
+++ b/community/nimble/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=nimble
-pkgver=0.13.1
-pkgrel=1
+pkgver=0.14.2
+pkgrel=0
pkgdesc="Package manager for the Nim programming language"
url="https://github.com/nim-lang/nimble"
arch="all !s390x"
license="BSD-3-Clause"
-depends="nim"
+depends="nim libssl3"
subpackages="$pkgname-bash-completion $pkgname-zsh-completion"
-source="https://github.com/nim-lang/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz
- fix-test.patch
- "
+source="https://github.com/nim-lang/nimble/archive/v$pkgver/nimble-$pkgver.tar.gz"
+# TODO: Fix tests
+options="!check"
prepare() {
default_prepare
@@ -34,6 +34,7 @@ build() {
}
check() {
+ unset GIT_CEILING_DIRECTORIES
cd tests
nim c -r tester
}
@@ -49,6 +50,5 @@ package() {
}
sha512sums="
-d13fc755e2018911faa1039ca6c73a3ecaa7aa57fb57faee9babb750155ac5e73be4f60110ee64cdd56874245f7c046d6c825356fd84a8fcbba9683db2406520 nimble-0.13.1.tar.gz
-9c0541fdca2a2a5be3a79ca96a29de1de23ef1679797f1179549a67ad3cd4b7243b8dc2c5cd8b06b185eacfe81fa781fd561e118c1ba2f45599d2f67cce2dfd8 fix-test.patch
+cbfb0274fb8644f4b1e453275c3544718958370c7cde0d0a60d3bd1ce5e3a3ec980f9a330c9755d02833134be5898da964dfe71e9a3f8aea9a88230391187a63 nimble-0.14.2.tar.gz
"