aboutsummaryrefslogtreecommitdiffstats
path: root/community/nlohmann-json/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nlohmann-json/APKBUILD')
-rw-r--r--community/nlohmann-json/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/nlohmann-json/APKBUILD b/community/nlohmann-json/APKBUILD
index 9523bdbf0d3..f92e1a66e66 100644
--- a/community/nlohmann-json/APKBUILD
+++ b/community/nlohmann-json/APKBUILD
@@ -1,15 +1,14 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nlohmann-json
-pkgver=3.10.5
+pkgver=3.11.3
pkgrel=0
pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
makedepends="cmake"
-subpackages="$pkgname-doc"
-source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
+source="https://github.com/nlohmann/json/archive/v$pkgver/nlohmann-json-$pkgver.tar.gz"
options="net" # Required for downloading test data
builddir="$srcdir/json-$pkgver"
@@ -20,22 +19,17 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DJSON_MultipleHeaders=ON
cmake --build build
-
- make -C doc
}
check() {
cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content_(configure|build)"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content(|2)_(configure|build)"
}
package() {
DESTDIR="$pkgdir" cmake --install build
-
- install -dm755 "$pkgdir"/usr/share/doc/$pkgname
- mv doc/mkdocs "$pkgdir"/usr/share/doc/$pkgname/
}
sha512sums="
-4a9d6416f383e76bf95425fc02a4e12c605fcbcae910b704e354396a493454cf8a1ffbecba11f231e020ffd2842908df7e67dbc09f62d1202d40b6815c24cfd2 nlohmann-json-3.10.5.tar.gz
+7df19b621de34f08d5d5c0a25e8225975980841ef2e48536abcf22526ed7fb99f88ad954a2cb823115db59ccc88d1dbe74fe6c281b5644b976b33fb78db9d717 nlohmann-json-3.11.3.tar.gz
"