aboutsummaryrefslogtreecommitdiffstats
path: root/community/nlohmann-json/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nlohmann-json/APKBUILD')
-rw-r--r--community/nlohmann-json/APKBUILD28
1 files changed, 10 insertions, 18 deletions
diff --git a/community/nlohmann-json/APKBUILD b/community/nlohmann-json/APKBUILD
index f08a4967a3a..f92e1a66e66 100644
--- a/community/nlohmann-json/APKBUILD
+++ b/community/nlohmann-json/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nlohmann-json
-pkgver=3.9.1
-pkgrel=1
+pkgver=3.11.3
+pkgrel=0
pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
-makedepends="cmake doxygen graphviz"
-subpackages="$pkgname-doc"
-source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
+makedepends="cmake"
+source="https://github.com/nlohmann/json/archive/v$pkgver/nlohmann-json-$pkgver.tar.gz"
+options="net" # Required for downloading test data
builddir="$srcdir/json-$pkgver"
build() {
@@ -19,25 +19,17 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DJSON_MultipleHeaders=ON
cmake --build build
-
- make -C doc
}
check() {
cd build
- local skipped_tests=
- if [ "$CARCH" = "aarch64" ]; then
- # test-unicode_all takes too long and times out
- skipped_tests="$skipped_tests|test-unicode_all"
- fi
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "($skipped_tests)"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content(|2)_(configure|build)"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname
- mv doc/html "$pkgdir"/usr/share/doc/$pkgname/
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="e0eb4727bea993af984f832e069d03a21219befae0f24ee49e67a1144cf1e8428dcf2e37f683aedb8d14118545d5087f2b7d822a576944cef3e590a12be51642 nlohmann-json-3.9.1.tar.gz"
+sha512sums="
+7df19b621de34f08d5d5c0a25e8225975980841ef2e48536abcf22526ed7fb99f88ad954a2cb823115db59ccc88d1dbe74fe6c281b5644b976b33fb78db9d717 nlohmann-json-3.11.3.tar.gz
+"