aboutsummaryrefslogtreecommitdiffstats
path: root/community/nlohmann-json/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nlohmann-json/APKBUILD')
-rw-r--r--community/nlohmann-json/APKBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/community/nlohmann-json/APKBUILD b/community/nlohmann-json/APKBUILD
index d4c407e75ca..f92e1a66e66 100644
--- a/community/nlohmann-json/APKBUILD
+++ b/community/nlohmann-json/APKBUILD
@@ -1,19 +1,14 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nlohmann-json
-pkgver=3.10.4
+pkgver=3.11.3
pkgrel=0
pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
-makedepends="
- cmake
- doxygen
- graphviz
- "
-subpackages="$pkgname-doc"
-source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
+makedepends="cmake"
+source="https://github.com/nlohmann/json/archive/v$pkgver/nlohmann-json-$pkgver.tar.gz"
options="net" # Required for downloading test data
builddir="$srcdir/json-$pkgver"
@@ -24,22 +19,17 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DJSON_MultipleHeaders=ON
cmake --build build
-
- make -C doc
}
check() {
cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content_(configure|build)"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content(|2)_(configure|build)"
}
package() {
DESTDIR="$pkgdir" cmake --install build
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname
- mv doc/html "$pkgdir"/usr/share/doc/$pkgname/
}
sha512sums="
-f78592db6218165cbc74c10bcba40366f1bfea84405b7ee25fe97a056d5b7a15aeeb956d93296673928dcbd6e26ffcfb152f885b4a44d5d55751396ccf090835 nlohmann-json-3.10.4.tar.gz
+7df19b621de34f08d5d5c0a25e8225975980841ef2e48536abcf22526ed7fb99f88ad954a2cb823115db59ccc88d1dbe74fe6c281b5644b976b33fb78db9d717 nlohmann-json-3.11.3.tar.gz
"