aboutsummaryrefslogtreecommitdiffstats
path: root/community/nlohmann-json/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nlohmann-json/APKBUILD')
-rw-r--r--community/nlohmann-json/APKBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/community/nlohmann-json/APKBUILD b/community/nlohmann-json/APKBUILD
index e6299484090..f92e1a66e66 100644
--- a/community/nlohmann-json/APKBUILD
+++ b/community/nlohmann-json/APKBUILD
@@ -1,15 +1,14 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nlohmann-json
-pkgver=3.10.2
+pkgver=3.11.3
pkgrel=0
pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
-makedepends="cmake doxygen graphviz"
-subpackages="$pkgname-doc"
-source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
+makedepends="cmake"
+source="https://github.com/nlohmann/json/archive/v$pkgver/nlohmann-json-$pkgver.tar.gz"
options="net" # Required for downloading test data
builddir="$srcdir/json-$pkgver"
@@ -20,22 +19,17 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DJSON_MultipleHeaders=ON
cmake --build build
-
- make -C doc
}
check() {
cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content_(configure|build)"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "cmake_fetch_content(|2)_(configure|build)"
}
package() {
DESTDIR="$pkgdir" cmake --install build
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname
- mv doc/html "$pkgdir"/usr/share/doc/$pkgname/
}
sha512sums="
-9a399dfc8aab19c9fc12470e8087895b1c05d48a9bcc731b483d8670c361cffb2adc3ccced822b7f17255e88387a441d619c4e1f1afeb702d1d035ad24fe22ed nlohmann-json-3.10.2.tar.gz
+7df19b621de34f08d5d5c0a25e8225975980841ef2e48536abcf22526ed7fb99f88ad954a2cb823115db59ccc88d1dbe74fe6c281b5644b976b33fb78db9d717 nlohmann-json-3.11.3.tar.gz
"