aboutsummaryrefslogtreecommitdiffstats
path: root/community/noise-repellent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/noise-repellent/APKBUILD')
-rw-r--r--community/noise-repellent/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/noise-repellent/APKBUILD b/community/noise-repellent/APKBUILD
index 2dc7784ed90..db58b28d459 100644
--- a/community/noise-repellent/APKBUILD
+++ b/community/noise-repellent/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Magnus Sandin <magnus.sandin@gmail.com>
# Maintainer: Magnus Sandin <magnus.sandin@gmail.com>
pkgname=noise-repellent
-pkgver=0.1.5
-pkgrel=0
-pkgdesc="An lv2 plug-in for broadband noise reduction"
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="lv2 plug-in for broadband noise reduction"
url="https://github.com/lucianodato/noise-repellent"
-arch="all !armhf !armv7 !ppc64le !s390x !riscv64" # -msse2
+arch="all"
license="LGPL-3.0-only"
makedepends="
+ cmake
fftw-dev
+ libspecbleach-dev
+ libsndfile-dev
lv2-dev
meson
"
-source="https://github.com/lucianodato/noise-repellent/archive/$pkgver/noise-repellent-$pkgver.tar.gz"
+source="noise-repellent-$pkgver.tar.gz::https://github.com/lucianodato/noise-repellent/archive/refs/tags/v$pkgver.tar.gz
+ no-useless-args.patch
+ "
options="!check" # No tests available
build() {
- # XXX: does not use paths correctly,
- # override prefix directly instead of using abuild-meson
- meson \
- --buildtype=plain \
- --prefix=/usr/lib/lv2 \
- -Db_pie=true \
+ abuild-meson \
+ -Db_lto=true \
+ --buildtype=release \
+ --prefix=/usr/lib \
. output
meson compile -C output
}
@@ -31,5 +34,6 @@ package() {
}
sha512sums="
-85fcafdaead400efa3ba9e87f2ecf96c02a41334f933902d456a2d5e714e72ef4124e68534f87b60421ef7139bea4e5e768a89d5ed13e6fcf95a9923cc89e383 noise-repellent-0.1.5.tar.gz
+102000459c1d2675c7366c4e2ce43fe8a5b055bcb4cbb5460e2e1241a4631bf3833f8d35fb1e07f03759ede0224541c7b3196452649366924c6fad6cccdccf17 noise-repellent-0.2.3.tar.gz
+eeb4efea46a9913a76ca79260edf1291f6e12b5776291f12e64ce9b2c7e0b695289bf325f039de331522effc6c7b294e4ab68f6eaf8738777a76407f390e179e no-useless-args.patch
"