aboutsummaryrefslogtreecommitdiffstats
path: root/community/nota/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nota/APKBUILD')
-rw-r--r--community/nota/APKBUILD44
1 files changed, 30 insertions, 14 deletions
diff --git a/community/nota/APKBUILD b/community/nota/APKBUILD
index 527e5a2aaf8..ba8583c9f8f 100644
--- a/community/nota/APKBUILD
+++ b/community/nota/APKBUILD
@@ -1,37 +1,52 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
+
+# optional dependencies:
+# * kio-extras: to enable thumbnails in the file browser
+# * udisks2: for browsing mount points
pkgname=nota
-pkgver=2.0.0
-pkgrel=1
+pkgver=3.0.2
+pkgrel=0
pkgdesc="Nota is a simple and convergent text editor"
# armhf blocked by qt5-qtdeclarative
-# s390x, ppc64le, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://invent.kde.org/maui/nota"
license="GPL-2.0-or-later"
depends="
+ kde-icons
mauikit-texteditor
+ qmltermwidget
+ qt5-qtbase-sqlite
"
makedepends="
- attica-dev
+ attica5-dev
extra-cmake-modules
- kconfig-dev
- ki18n-dev
- kio-dev
- knotifications-dev
+ kconfig5-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
mauikit-dev
mauikit-filebrowsing-dev
+ mauikit-texteditor-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtsvg-dev
qt5-qtwebengine-dev
- syntax-highlighting-dev
+ samurai
+ syntax-highlighting5-dev
"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/nota.git"
source="https://download.kde.org/stable/maui/nota/$pkgver/nota-$pkgver.tar.xz"
options="!check" # No tests available
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -40,6 +55,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-381dcd005e8790a2c8d70707ef8f5a1e863f44298d45ab6e8f6f545924024ae57bb2b256e1ddb6fbe079a766ffdc2bbca370392f01e853dce209acb4817beb89 nota-2.0.0.tar.xz
+727a9e231c2dc8c2a1965fbddb3544fff9718190263a14c9f2d1266ab9ad85eda958bb791c292784117e371f2b635c6d6e6f4545381086b8a0f061baf2d40e2f nota-3.0.2.tar.xz
"