aboutsummaryrefslogtreecommitdiffstats
path: root/community/notcurses/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notcurses/APKBUILD')
-rw-r--r--community/notcurses/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/community/notcurses/APKBUILD b/community/notcurses/APKBUILD
index 09de462baf2..f9570cd58e8 100644
--- a/community/notcurses/APKBUILD
+++ b/community/notcurses/APKBUILD
@@ -1,46 +1,46 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Nick Black <dankamongmen@gmail.com>
pkgname=notcurses
-pkgver=2.4.9
-pkgrel=0
+pkgver=3.0.9
+pkgrel=2
pkgdesc="blingful character graphics and TUI library"
url="https://nick-black.com/dankwiki/index.php/Notcurses"
arch="all"
license="Apache-2.0"
# FIXME gpm-libs is still in testing. once it moves to community, dep on it,
# and add -DUSE_GPM=on to build().
-makedepends="cmake doctest-dev ffmpeg-dev libunistring-dev linux-headers ncurses-dev ncurses-terminfo zlib-dev"
+makedepends="cmake doctest-dev ffmpeg-dev libdeflate-dev libunistring-dev
+ linux-headers ncurses-dev ncurses-terminfo samurai"
subpackages="$pkgname-dbg $pkgname-static $pkgname-dev $pkgname-doc
$pkgname-libs $pkgname-demo ncneofetch ncls $pkgname-view $pkgname-tetris"
source="https://github.com/dankamongmen/notcurses/archive/v$pkgver/notcurses-$pkgver.tar.gz
https://github.com/dankamongmen/notcurses/releases/download/v$pkgver/notcurses-doc-$pkgver.tar.gz
"
-
-# Don't run tests on mips64, builder is too slow.
-[ "$CARCH" = "mips64" ] && options="!check"
-[ "$CARCH" = "riscv64" ] && options="textrels"
+options="$options !check"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_PANDOC=off \
-DUSE_QRCODEGEN=off \
$CMAKE_CROSSOPTS
- make -C build
+ cmake --build build
}
check() {
- env TERM=vt100 CTEST_OUTPUT_ON_FAILURE=1 make -C build test
+ TERM=vt100 \
+ setsid ctest -V --output-on-failure --test-dir build \
+ &>/tmp/log
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
for i in 1 3 ; do
find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec echo "$pkgdir"/usr/share/man/man$i {} \;
find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec install -Dm644 -t "$pkgdir"/usr/share/man/man$i {} \;
@@ -75,6 +75,6 @@ tetris() {
}
sha512sums="
-c8774a8b413fb00a0051e4067419785d9fe958c56df0eeecb42c3e0430788bb039e355c8bbcdc63f0bcbc2c33ca0d130d05dbbfdb22a12bc4c9c8d1529976b33 notcurses-2.4.9.tar.gz
-8bb490c8297a9cc8f99cac46172d5c2a6bc376725e03eaeb6a0495ed8a712d7c31998b7c8b511dfc1b69a3e082fdb1dba1e4d4d2d05cc5a9bddcc547e682fe4e notcurses-doc-2.4.9.tar.gz
+e867d2436f7c953b4b7feb1464b73709cb792256e82956c933c43981dad802c30526d53d28ebafd8e460a3309ae4895cac4e0d1f6f89e347ab9578546798d19b notcurses-3.0.9.tar.gz
+9824b2d0210b2387c3cbee9b3f79e5bf6ca284222ba42ff2f9a427216110c2bcf021203a87a9b3947be99d1662a2597be9d4657a73e20b5d9b605576abde8df0 notcurses-doc-3.0.9.tar.gz
"