aboutsummaryrefslogtreecommitdiffstats
path: root/community/notcurses/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notcurses/APKBUILD')
-rw-r--r--community/notcurses/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/community/notcurses/APKBUILD b/community/notcurses/APKBUILD
index 72757bd7fcc..f9570cd58e8 100644
--- a/community/notcurses/APKBUILD
+++ b/community/notcurses/APKBUILD
@@ -1,46 +1,46 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Nick Black <dankamongmen@gmail.com>
pkgname=notcurses
-pkgver=2.4.7
-pkgrel=0
+pkgver=3.0.9
+pkgrel=2
pkgdesc="blingful character graphics and TUI library"
url="https://nick-black.com/dankwiki/index.php/Notcurses"
arch="all"
license="Apache-2.0"
# FIXME gpm-libs is still in testing. once it moves to community, dep on it,
# and add -DUSE_GPM=on to build().
-makedepends="cmake doctest-dev ffmpeg-dev libunistring-dev linux-headers ncurses-dev ncurses-terminfo zlib-dev"
+makedepends="cmake doctest-dev ffmpeg-dev libdeflate-dev libunistring-dev
+ linux-headers ncurses-dev ncurses-terminfo samurai"
subpackages="$pkgname-dbg $pkgname-static $pkgname-dev $pkgname-doc
$pkgname-libs $pkgname-demo ncneofetch ncls $pkgname-view $pkgname-tetris"
source="https://github.com/dankamongmen/notcurses/archive/v$pkgver/notcurses-$pkgver.tar.gz
https://github.com/dankamongmen/notcurses/releases/download/v$pkgver/notcurses-doc-$pkgver.tar.gz
"
-
-# Don't run tests on mips64, builder is too slow.
-[ "$CARCH" = "mips64" ] && options="!check"
-[ "$CARCH" = "riscv64" ] && options="textrels"
+options="$options !check"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_PANDOC=off \
-DUSE_QRCODEGEN=off \
$CMAKE_CROSSOPTS
- make -C build
+ cmake --build build
}
check() {
- env TERM=vt100 CTEST_OUTPUT_ON_FAILURE=1 make -C build test
+ TERM=vt100 \
+ setsid ctest -V --output-on-failure --test-dir build \
+ &>/tmp/log
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
for i in 1 3 ; do
find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec echo "$pkgdir"/usr/share/man/man$i {} \;
find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec install -Dm644 -t "$pkgdir"/usr/share/man/man$i {} \;
@@ -75,6 +75,6 @@ tetris() {
}
sha512sums="
-6c99517a02fa6c8b97a4d1633460476a9fbbc8f6c8c361038749c1f9cd7262092f334d06b20bf0c0fedfa89c0631ed6d37c7bd71a8967c1708cc631524a44f51 notcurses-2.4.7.tar.gz
-7fbd8d4be2b8d20658ba6a5b7cb0735355fba17f30bba46a28ce1be53a624a22164af667d0c7cced5cb49b5b5ddf8b73093260118f2e90b1255552f1d123ef6b notcurses-doc-2.4.7.tar.gz
+e867d2436f7c953b4b7feb1464b73709cb792256e82956c933c43981dad802c30526d53d28ebafd8e460a3309ae4895cac4e0d1f6f89e347ab9578546798d19b notcurses-3.0.9.tar.gz
+9824b2d0210b2387c3cbee9b3f79e5bf6ca284222ba42ff2f9a427216110c2bcf021203a87a9b3947be99d1662a2597be9d4657a73e20b5d9b605576abde8df0 notcurses-doc-3.0.9.tar.gz
"