aboutsummaryrefslogtreecommitdiffstats
path: root/community/notcurses/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notcurses/APKBUILD')
-rw-r--r--community/notcurses/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/community/notcurses/APKBUILD b/community/notcurses/APKBUILD
index 40baecf50a1..f9570cd58e8 100644
--- a/community/notcurses/APKBUILD
+++ b/community/notcurses/APKBUILD
@@ -1,45 +1,46 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
# Maintainer: Nick Black <dankamongmen@gmail.com>
pkgname=notcurses
-pkgver=3.0.0
-pkgrel=0
+pkgver=3.0.9
+pkgrel=2
pkgdesc="blingful character graphics and TUI library"
url="https://nick-black.com/dankwiki/index.php/Notcurses"
arch="all"
license="Apache-2.0"
# FIXME gpm-libs is still in testing. once it moves to community, dep on it,
# and add -DUSE_GPM=on to build().
-makedepends="cmake doctest-dev ffmpeg-dev libdeflate-dev libunistring-dev linux-headers ncurses-dev ncurses-terminfo"
+makedepends="cmake doctest-dev ffmpeg-dev libdeflate-dev libunistring-dev
+ linux-headers ncurses-dev ncurses-terminfo samurai"
subpackages="$pkgname-dbg $pkgname-static $pkgname-dev $pkgname-doc
$pkgname-libs $pkgname-demo ncneofetch ncls $pkgname-view $pkgname-tetris"
source="https://github.com/dankamongmen/notcurses/archive/v$pkgver/notcurses-$pkgver.tar.gz
https://github.com/dankamongmen/notcurses/releases/download/v$pkgver/notcurses-doc-$pkgver.tar.gz
- 10-putc-precopy.patch
"
-
-[ "$CARCH" = "riscv64" ] && options="textrels"
+options="$options !check"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_PANDOC=off \
-DUSE_QRCODEGEN=off \
$CMAKE_CROSSOPTS
- make -C build
+ cmake --build build
}
check() {
- env TERM=vt100 CTEST_OUTPUT_ON_FAILURE=1 make -C build test
+ TERM=vt100 \
+ setsid ctest -V --output-on-failure --test-dir build \
+ &>/tmp/log
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
for i in 1 3 ; do
find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec echo "$pkgdir"/usr/share/man/man$i {} \;
find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec install -Dm644 -t "$pkgdir"/usr/share/man/man$i {} \;
@@ -74,7 +75,6 @@ tetris() {
}
sha512sums="
-0bc2a5256feb73a047b7d9c9fb69809aeee41c21a564f7c4be1cd3c0ab6fe68b3db2c5959f678748a2340203e8822459c370b674a3ef6867c17b4b63956f5d25 notcurses-3.0.0.tar.gz
-ab4ddac027963c5c9203f48a4a51bdcecaca28cef3158c7cc505f48eb89eee9b7f3399f0fa1919ee8959b69139a051c860c72b5feef9e417750fb3141f521ab6 notcurses-doc-3.0.0.tar.gz
-ab0c8533eac5feb6b167dcb4c6b814474391f8fd9a1709c445bb113cc41e76d7622ba12a2b72988e1f1414181fa27245e2cfe2ca61d4ba0fd5e9beab2c18fe59 10-putc-precopy.patch
+e867d2436f7c953b4b7feb1464b73709cb792256e82956c933c43981dad802c30526d53d28ebafd8e460a3309ae4895cac4e0d1f6f89e347ab9578546798d19b notcurses-3.0.9.tar.gz
+9824b2d0210b2387c3cbee9b3f79e5bf6ca284222ba42ff2f9a427216110c2bcf021203a87a9b3947be99d1662a2597be9d4657a73e20b5d9b605576abde8df0 notcurses-doc-3.0.9.tar.gz
"