aboutsummaryrefslogtreecommitdiffstats
path: root/community/notcurses/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notcurses/APKBUILD')
-rw-r--r--community/notcurses/APKBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/community/notcurses/APKBUILD b/community/notcurses/APKBUILD
new file mode 100644
index 00000000000..f9570cd58e8
--- /dev/null
+++ b/community/notcurses/APKBUILD
@@ -0,0 +1,80 @@
+# Contributor: Nick Black <dankamongmen@gmail.com>
+# Maintainer: Nick Black <dankamongmen@gmail.com>
+pkgname=notcurses
+pkgver=3.0.9
+pkgrel=2
+pkgdesc="blingful character graphics and TUI library"
+url="https://nick-black.com/dankwiki/index.php/Notcurses"
+arch="all"
+license="Apache-2.0"
+# FIXME gpm-libs is still in testing. once it moves to community, dep on it,
+# and add -DUSE_GPM=on to build().
+makedepends="cmake doctest-dev ffmpeg-dev libdeflate-dev libunistring-dev
+ linux-headers ncurses-dev ncurses-terminfo samurai"
+subpackages="$pkgname-dbg $pkgname-static $pkgname-dev $pkgname-doc
+ $pkgname-libs $pkgname-demo ncneofetch ncls $pkgname-view $pkgname-tetris"
+source="https://github.com/dankamongmen/notcurses/archive/v$pkgver/notcurses-$pkgver.tar.gz
+ https://github.com/dankamongmen/notcurses/releases/download/v$pkgver/notcurses-doc-$pkgver.tar.gz
+ "
+options="$options !check"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DUSE_PANDOC=off \
+ -DUSE_QRCODEGEN=off \
+ $CMAKE_CROSSOPTS
+ cmake --build build
+}
+
+check() {
+ TERM=vt100 \
+ setsid ctest -V --output-on-failure --test-dir build \
+ &>/tmp/log
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+ for i in 1 3 ; do
+ find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec echo "$pkgdir"/usr/share/man/man$i {} \;
+ find "$srcdir" -maxdepth 1 -type f -iname \*.$i -exec install -Dm644 -t "$pkgdir"/usr/share/man/man$i {} \;
+ done
+}
+
+libs() {
+ amove usr/lib/libnotcurses*.so.*
+}
+
+demo() {
+ amove usr/bin/notcurses-demo
+ amove usr/bin/notcurses-tester
+ amove usr/bin/notcurses-info
+ amove usr/share/notcurses
+}
+
+ncneofetch() {
+ amove usr/bin/ncneofetch
+}
+
+ncls() {
+ amove usr/bin/ncls
+}
+
+view() {
+ amove usr/bin/ncplayer
+}
+
+tetris() {
+ amove usr/bin/nctetris
+}
+
+sha512sums="
+e867d2436f7c953b4b7feb1464b73709cb792256e82956c933c43981dad802c30526d53d28ebafd8e460a3309ae4895cac4e0d1f6f89e347ab9578546798d19b notcurses-3.0.9.tar.gz
+9824b2d0210b2387c3cbee9b3f79e5bf6ca284222ba42ff2f9a427216110c2bcf021203a87a9b3947be99d1662a2597be9d4657a73e20b5d9b605576abde8df0 notcurses-doc-3.0.9.tar.gz
+"