aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notmuch/APKBUILD')
-rw-r--r--community/notmuch/APKBUILD108
1 files changed, 57 insertions, 51 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index e1160be7256..e9124996f93 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -1,57 +1,73 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
-# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=notmuch
-pkgver=0.34
-pkgrel=0
+pkgver=0.38.3
+pkgrel=1
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
license="GPL-3.0-or-later"
makedepends="
- bash-completion
+ bash
+ bash-completion-dev
emacs-nox
gmime-dev
gzip
perl
- py3-charset-normalizer
+ py3-gpep517
py3-requests
+ py3-setuptools
py3-sphinx
+ py3-wheel
python3-dev
talloc-dev
xapian-core-dev
"
-checkdepends="bash coreutils dtach mandoc sed tar"
+checkdepends="
+ coreutils
+ dtach
+ mandoc
+ sed
+ tar
+ "
subpackages="
+ py3-$pkgname-pyc
py3-$pkgname:py3:noarch
$pkgname-doc
$pkgname-dev
$pkgname-libs
$pkgname-emacs:emacs:noarch
$pkgname-vim:vim:noarch
- $pkgname-zsh-completion:zshcomp:noarch
- $pkgname-bash-completion:bashcomp:noarch"
-source="https://notmuchmail.org/releases/notmuch-$pkgver.tar.xz"
+ $pkgname-zsh-completion
+ $pkgname-bash-completion"
+source="https://notmuchmail.org/releases/notmuch-$pkgver.tar.xz
+ test-musl-invalid-regexp.patch
+ "
+
+prepare() {
+ default_prepare
+ git init -q .
+}
build() {
- PYTHON=python3 ./configure \
+ CFLAGS="$CFLAGS -flto=auto" \
+ ./configure \
--build="$CBUILD" \
--host="$CHOST" \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
+ --without-rpath \
--bashcompletiondir=/usr/share/bash-completion/completions \
--zshcompletiondir=/usr/share/zsh/site-functions
- make PREFIX=/usr DESTDIR="$pkgdir"
+ make
cd bindings/python
- python3 setup.py build
-}
-
-package() {
- make PREFIX=/usr DESTDIR="$pkgdir" \
- -C "$builddir" install
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -62,6 +78,8 @@ check() {
for test in T*.sh; do
name="$(basename "$test")"
case "${name%%.*}" in
+ # seems to have an extra Cc: and fail
+ T220-reply) continue ;;
# Requires dtach ↦ doesn't work on the builders
*emacs*|T355-smime|T350-crypto) continue ;;
@@ -73,61 +91,49 @@ check() {
# FIXME: These should pass but currently don't
T150-tagging|T060-count|T070-insert|T357-index-decryption) continue ;;
+
+ # Requires Python bindings installed
+ T055-path-config) continue ;;
esac
./$test
done
}
-vim() {
- depends="vim notmuch"
- pkgdesc="Vim plugins for $pkgname"
+package() {
+ make DESTDIR="$pkgdir" install
- make -C "$builddir/vim" DESTDIR="$subpkgdir" \
+ cd bindings/python
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+
+ make -C "$builddir"/vim DESTDIR="$pkgdir" \
prefix="/usr/share/vim/vimfiles" install
}
-emacs() {
- depends="emacs notmuch"
- pkgdesc="Emacs plugins for $pkgname"
-
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/emacs/ "$subpkgdir"/usr/share/emacs/
+vim() {
+ depends="vim notmuch=$pkgver-r$pkgrel"
+ pkgdesc="Vim plugins for $pkgname"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/notmuch-emacs-mua "$subpkgdir"/usr/bin/
+ amove usr/share/vim
}
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
- mv "$pkgdir"/usr/share/bash-completion/completions/$pkgname \
- "$subpkgdir"/usr/share/bash-completion/completions/
- rm -rf "$pkgdir"/usr/share/bash-completion
-}
+emacs() {
+ depends="emacs notmuch=$pkgver-r$pkgrel"
+ pkgdesc="Emacs plugins for $pkgname"
-zshcomp() {
- depends=""
- pkgdesc="Zsh completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ amove usr/share/emacs
- mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
- mv "$pkgdir"/usr/share/zsh/site-functions/_$pkgname \
- "$subpkgdir"/usr/share/zsh/site-functions/
- rm -rf "$pkgdir"/usr/share/zsh
+ amove usr/bin/notmuch-emacs-mua
}
py3() {
pkgdesc="$pkgdesc (for python3)"
- depends="$depends python3"
+ depends="py3-cffi"
- cd "$builddir"/bindings/python
- python3 setup.py install --prefix=/usr --root="$subpkgdir"
+ amove usr/lib/python3*
}
sha512sums="
-c7c802ee6fc056cb626611e3403541e404c628d238983299faf877e7eca9dfb94bd643c399e6a6cda53b051d2ad837ad03b124a1f44e17c7637a9c9b23e33c73 notmuch-0.34.tar.xz
+247f8b365a75b29df719403bc2c9645eb669a7ee6eb4c1e0047dcf55fea4d66c8dcb4899162b952643aa6148ec6e1538ebe3e7e8408376153165e394084aed19 notmuch-0.38.3.tar.xz
+0defaeb6781694d55f2e11a5ede37214d261bab4eed328d523cfda80deb11085a1486aa13e180cebc3b24dddfa073d17f7b9e2891c176d60aafa62509a28d55c test-musl-invalid-regexp.patch
"