aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notmuch/APKBUILD')
-rw-r--r--community/notmuch/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 4f393d29532..1792db5f1ce 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
-pkgver=0.25.3
-pkgrel=1
+pkgver=0.27
+pkgrel=0
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
@@ -17,13 +17,13 @@ subpackages="
$pkgname-dev
$pkgname-doc
$pkgname-libs
- $pkgname-emacs:emacs
+ $pkgname-emacs:emacs:noarch
$pkgname-vim:vim:noarch
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
fix-tests.patch
- fix-tests-for-python3.patch"
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -62,10 +62,10 @@ check() {
*emacs*|T355-smime|T350-crypto) continue ;;
# XXX: Doesn't pass on the builders for some reason
- T140-excludes) continue ;;
+ T050-new|T140-excludes) continue ;;
# FIXME: These should pass but currently don't
- T050-new|T150-tagging|T060-count) continue ;;
+ T150-tagging|T060-count|T070-insert|T357-index-decryption) continue ;;
esac
./${test}
@@ -99,6 +99,7 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
mv "$pkgdir"/usr/share/bash-completion/completions/$pkgname \
"$subpkgdir"/usr/share/bash-completion/completions/
+ rm -rf "$pkgdir"/usr/share/bash-completion
}
zshcomp() {
@@ -109,6 +110,7 @@ zshcomp() {
mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
mv "$pkgdir"/usr/share/zsh/site-functions/_${pkgname} \
"$subpkgdir"/usr/share/zsh/site-functions/
+ rm -rf "$pkgdir"/usr/share/zsh
}
_py() {
@@ -129,6 +131,5 @@ py3() {
_py python3
}
-sha512sums="1c0fcfdeb7a7eddcd10a8175676679ef6985407732d5bcc15edd327d9985017696cef3287c0398c628a604ae3fbab5d222d71537e37265cf6a594b4914e4599a notmuch-0.25.3.tar.gz
-430e8f02b194b0582dfd7c66a2791a0071824e1d215993a6daf89c8d2a1ee7f73a6202136b1d890fc8920a4dc309ae976da8a8b8fc8b90e489d3c04f1592876c fix-tests.patch
-a7dd888c5d08835be75986e67afcbc95c7a65c187fab5b0eb969bb36e9bbbc2d647789f106f709a38906eed51e3684a3241678ace1fc8c4b5e1cdbdd06fb6bbb fix-tests-for-python3.patch"
+sha512sums="7c58c6fe5c3b43a979c3a439a24106417120726fd688b456d9084388ddd7c88ab1b6d99cd4676101f085d60bb37099631caa286b76588fcb041bb004ff325515 notmuch-0.27.tar.gz
+582484067b5899ec74f82c29b32b459670fc752365b9c09392b44538921aa6b106f56350d18d12cf51bfeac1a02b79c9026057111a7aa2016c75345e19e96da4 fix-tests.patch"