aboutsummaryrefslogtreecommitdiffstats
path: root/community/npm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/npm/APKBUILD')
-rw-r--r--community/npm/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/npm/APKBUILD b/community/npm/APKBUILD
index 4af35df9eb0..da4d5a78fad 100644
--- a/community/npm/APKBUILD
+++ b/community/npm/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=npm
-pkgver=8.10.0
+pkgver=10.5.1
pkgrel=0
pkgdesc="The package manager for JavaScript"
-url="https://npm.community"
-arch="noarch !riscv64" # blocked by nodejs
+url="https://www.npmjs.com/"
+arch="noarch"
license="Artistic-2.0"
depends="cmd:node"
replaces="nodejs-doc" # for backward compatibility
@@ -26,7 +26,7 @@ prepare() {
# Remove bunch of unnecessary files to reduce size of the package.
# Wrapper scripts written in Bash and CMD.
- rm bin/npm bin/npx bin/*.cmd bin/node-gyp-bin/*.cmd
+ rm bin/npm bin/npx bin/*.cmd
rm README.md
# HTML docs
rm -rf docs
@@ -59,7 +59,7 @@ prepare() {
for f in man5/folders.5 man5/install.5 man7/*.7; do
sec=${f##*.}
name=$(basename $f .$sec)
- title=$(echo "$name" | tr '[a-z]' '[A-Z]')
+ title=$(echo "$name" | tr '[:lower:]' '[:upper:]')
sed -Ei "s/^\.TH \"$title\"/.TH \"NPM-$title\"/" "$f"
mv "$f" "${f%/*}/npm-$name.$sec"
@@ -103,7 +103,7 @@ doc() {
}
sha512sums="
-ea8a3ae6af50baff6644f19926e7e6487f82fd415d81e970cd15e28254ffda60c1e74cddcbf9592b97456344c9f5f27ff201ea9f1717d4d336d3a28b8d304c95 npm-8.10.0.tgz
-7b0c309fc5c4aeba48f95968ec3b5234a3a96b3b47be65337a2e8f28109a6b7ed4fbb6eb9d9bbad0ed329a21eb9c1a45744c56dfa775f5ac4b852a1d07e7a86a dont-check-for-last-version.patch
+468cd9b86b966db843336b1184e48b2116f70cbca87fa4d1122d135b96f7c54101ae8a43843a841efd22023035cec2305ca81f22447c1af40c778a1e28a83d79 npm-10.5.1.tgz
+6b174bbf8eecdd62ec3b7fec646ec0ff84d371f18194fe482b4ed37ae3642f4d0992609152608ad068e4d1bb72be22ff44d96a28709f870d84b4b62737cb6238 dont-check-for-last-version.patch
6d0ce425061ffff1c5d7a42c9908f3382cd77abf81a9c30a62ff6fff1f0d02ff633b2bb090814aa619f7d2a51237b3da7f85d97d0f584e037639b60ccfaf0e96 npmrc
"