aboutsummaryrefslogtreecommitdiffstats
path: root/community/nq
diff options
context:
space:
mode:
Diffstat (limited to 'community/nq')
-rw-r--r--community/nq/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/nq/APKBUILD b/community/nq/APKBUILD
new file mode 100644
index 00000000000..c09db8695ff
--- /dev/null
+++ b/community/nq/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname="nq"
+pkgver="0.3.1"
+pkgrel=0
+pkgdesc="Unix command line queue utility"
+url="https://github.com/leahneukirchen/nq"
+arch="all"
+license="CC0-1.0"
+subpackages="$pkgname-doc"
+source="nq-$pkgver.tar.gz::https://github.com/leahneukirchen/nq/archive/v$pkgver.tar.gz"
+builddir="$srcdir/nq-$pkgver"
+checkdepends="perl-utils"
+
+build() {
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="42a43eb90488e17439d12740268b66cf6ed6f255ee0377f2df02f97fe2cdd562726e06909fb8efa26e3740e885088083f0880d986bf3f58615a21f1ea4c11d87 nq-0.3.1.tar.gz"