aboutsummaryrefslogtreecommitdiffstats
path: root/community/nqp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nqp/APKBUILD')
-rw-r--r--community/nqp/APKBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/community/nqp/APKBUILD b/community/nqp/APKBUILD
index b29e885715e..66607514305 100644
--- a/community/nqp/APKBUILD
+++ b/community/nqp/APKBUILD
@@ -1,38 +1,47 @@
# Contributor: Curt Tilmes <Curt.Tilmes@nasa.gov>
# Maintainer: Curt Tilmes <Curt.Tilmes@nasa.gov>
pkgname=nqp
-pkgver=2021.08
+pkgver=2024.03
pkgrel=0
pkgdesc="Not Quite Perl"
url="https://github.com/Raku/nqp"
# riscv64 blocked by moarvm
-arch="all !x86 !armhf !armv7 !s390x !riscv64"
+# ppc64le, s390x: fails check
+arch="all !ppc64le !s390x !riscv64"
options="!archcheck" # Arch dependencies are embedded
license="Artistic-2.0"
-depends="moarvm"
-makedepends="perl-utils moarvm-dev libffi-dev"
+depends="moarvm~$pkgver"
+makedepends="perl-utils moarvm-dev~$pkgver"
+checkdepends="perl-test-harness"
subpackages="$pkgname-doc"
source="https://github.com/Raku/nqp/releases/download/$pkgver/nqp-$pkgver.tar.gz"
build() {
perl Configure.pl --prefix=/usr --backends=moar
- make
+ make -j"$JOBS"
}
check() {
- make test
+ # Tests take too long to run on these architectures
+ if [ "$CARCH" = "x86" ] || [ "$CARCH" = "armhf" ]; then
+ ./nqp -V
+ else
+ export TEST_JOBS=$JOBS
+ export HARNESS_VERBOSE=1
+
+ msg "Running $TEST_JOBS parallel test jobs"
+ make test
+ fi
}
package() {
make DESTDIR="$pkgdir" install
-}
-doc() {
- cd "$builddir"
- mkdir -p "$subpkgdir"/usr/share/doc/"$pkgname"
- for file in CREDITS LICENSE README.pod VERSION docs examples; do
- cp -r $file "$subpkgdir"/usr/share/doc/"$pkgname"
- done
+ install -Dvm644 CREDITS LICENSE README.pod VERSION \
+ -t "$pkgdir"/usr/share/doc/"$pkgname"
+ cp -vr docs examples "$pkgdir"/usr/share/doc/"$pkgname"/
}
-sha512sums="fca1dc8c36f914304f97330cb33be3a94c539f3cb6cc80d898c734dcf04b12b8be30ffce358a0a5320c6ea56afd627f792b4a8fa3f94134776922ae088b92814 nqp-2021.08.tar.gz"
+sha512sums="
+e35b388b8546d4a02522e18fe03964475ec7128e3703aa8f0a56225f67c8301391287a218d903ff67176cbbf56055607468c9365837800dbb631bbcb46a9652a nqp-2024.03.tar.gz
+"