aboutsummaryrefslogtreecommitdiffstats
path: root/community/numberstation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/numberstation/APKBUILD')
-rw-r--r--community/numberstation/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/numberstation/APKBUILD b/community/numberstation/APKBUILD
new file mode 100644
index 00000000000..2664b1c9f77
--- /dev/null
+++ b/community/numberstation/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Martijn Braam <martijn@brixit.nl>
+pkgname=numberstation
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="TOTP Authentication application for mobile"
+url="https://git.sr.ht/~martijnbraam/numberstation"
+# riscv64, s390x blocked by libhandy1, ppc64le blocked by py3-keyring
+arch="noarch !ppc64le"
+license="GPL-3.0-or-later"
+depends="
+ gtk+3.0
+ libhandy1
+ py3-gobject3
+ py3-keyring
+ py3-otp
+ python3
+ "
+makedepends="
+ glib-dev
+ libhandy1-dev
+ meson
+ ninja
+ py3-setuptools
+ "
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~martijnbraam/numberstation/archive/$pkgver.tar.gz"
+options="!check" # There's no testsuite
+
+build() {
+ abuild-meson . output
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+sha512sums="
+da3065cb233c2933fa2cb85ec8f803449f92d4fd19a83ffc9f4229966da4c68a4029d223a61989b78695244690f95047cde106cbba5bda0aa41582391d48fcc2 numberstation-1.3.0.tar.gz
+"