aboutsummaryrefslogtreecommitdiffstats
path: root/community/nut/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nut/APKBUILD')
-rw-r--r--community/nut/APKBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/community/nut/APKBUILD b/community/nut/APKBUILD
index bbff3bd2166..65c11906fc4 100644
--- a/community/nut/APKBUILD
+++ b/community/nut/APKBUILD
@@ -2,30 +2,41 @@
# Contributor: Kozak Ivan <kozak-iv@yandex.ru>
# Maintainer: Kozak Ivan <kozak-iv@yandex.ru>
pkgname=nut
-pkgver=2.8.0
-pkgrel=1
+pkgver=2.8.2
+pkgrel=0
pkgdesc="Network UPS tools"
url="https://networkupstools.org/"
arch="all"
license="GPL-2.0-or-later"
depends="hidapi eudev udev-init-scripts-openrc"
-depends_dev="openssl-dev libmodbus-dev libusb-dev net-snmp-dev neon-dev nss-dev"
+depends_dev="openssl-dev>3 libmodbus-dev libusb-dev net-snmp-dev neon-dev nss-dev"
makedepends="$depends_dev libtool autoconf automake"
pkgusers=$pkgname
pkggroups=$pkgname
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion $pkgname-openrc"
source="https://networkupstools.org/source/${pkgver%.*}/nut-$pkgver.tar.gz
+ powerfail.initd
upsd.initd
upsmon.initd
"
prepare() {
default_prepare
- autoreconf -vif
+
+ # fix version
+ git init .
+ git config user.name "abc"
+ git config user.email "a@a"
+ git add configure.ac
+ git commit -m "$pkgver"
+ git tag "$pkgver"
+
+ autoreconf -fi
}
build() {
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -58,11 +69,12 @@ build() {
}
check() {
- make -C "$builddir" check
+ make check
}
package() {
- make -C "$builddir" DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
+ install -Dm755 "$srcdir"/powerfail.initd "$pkgdir"/etc/init.d/nut-powerfail.initd
install -Dm755 "$srcdir"/upsd.initd "$pkgdir"/etc/init.d/nut-upsd
install -Dm755 "$srcdir"/upsmon.initd "$pkgdir"/etc/init.d/nut-upsmon
install -Dm644 "$builddir"/scripts/logrotate/nutlogd "$pkgdir"/etc/logrotate.d/$pkgname
@@ -80,7 +92,8 @@ package() {
}
sha512sums="
-3c413ae54088045a713eb80cf1bdda474f41bb3b67c7c0248aa7a0c4d441dce1ff42627a2735273d7e36892d1f2eeb895220cf28af63fec2fa0c7a267f82d577 nut-2.8.0.tar.gz
+b6f8f22318e4a4fcb8073a63132b1cb083952c665191b82a7d6765a61b859575a4b0c2ba84ed17cfb8c88d34179876d64520dd2f75f02fe8707b406da2c0821c nut-2.8.2.tar.gz
+c32f693e9882602f847b714d2837172b18c0b2fb78cbbf95c0af43a59b3213e3241327890ae038573a9de114ab33bb43d69796c4683b5120ca49cd3174dd5f2d powerfail.initd
5fce1247815e36a0e787f28dfec215077a42b046f6ce35a5ad3cf94479dfc26303d3cf4d5f760d5851ed5273ee398572c36cd354af0645cbebc1f1560414e222 upsd.initd
32470ae473fc363131787cd57f13d40763898947d56d032790ba7f3a5eaa8038b602f7e395ca44f6c5adce8ee5ec496e30ca0eaadb3c78a38015677aea751e12 upsmon.initd
"