aboutsummaryrefslogtreecommitdiffstats
path: root/community/nuttcp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nuttcp/APKBUILD')
-rw-r--r--community/nuttcp/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/nuttcp/APKBUILD b/community/nuttcp/APKBUILD
index d729d172148..7d39e064feb 100644
--- a/community/nuttcp/APKBUILD
+++ b/community/nuttcp/APKBUILD
@@ -1,24 +1,26 @@
# Contributor: Danilo Godec <danilo.godec@agenda.si>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nuttcp
-pkgver=8.1.4
-pkgrel=0
+pkgver=8.2.2
+pkgrel=1
pkgdesc="A network performance measurement tool"
url="http://www.nuttcp.net"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-only"
makedepends="linux-headers"
-source="http://nuttcp.net/nuttcp/nuttcp-$pkgver/nuttcp-$pkgver.c"
+subpackages="$pkgname-doc"
+source="http://nuttcp.net/nuttcp/nuttcp-$pkgver/nuttcp-$pkgver.c
+ http://nuttcp.net/nuttcp/nuttcp-$pkgver/nuttcp.8"
builddir="$srcdir"
build() {
- cd "$builddir"
${CC:-gcc} $CFLAGS -o nuttcp $LDFLAGS nuttcp-$pkgver.c
}
package() {
- cd "$builddir"
install -Dm755 nuttcp "$pkgdir"/usr/sbin/nuttcp
+ install -Dm644 nuttcp.8 "$pkgdir"/usr/share/man/man8/nuttcp.8
}
-sha512sums="5bc1505d708ed9555c03bb5358f8a94f483b725d99c5b1de74447a888bb4d9485385602538d7be2b56026a87f9fd2255744e7528f92cfb5fe54f5f4ab7c2e1fc nuttcp-8.1.4.c"
+sha512sums="1a52ac7dd3a4a54806567944120a1e211408ac294342a62e6be11a157018cecb4f964435ceaad1e64ff6ca5c2e83911a68ede3aadd0e23edf739d849c74ca6d3 nuttcp-8.2.2.c
+e50621871fd60fe95a078b1f5c70e1e629c68ff14a7ddefccd1cd3831f8ede904ee6f84fa048cfb71e35285f29b71b47160cf707feefaf23d7496e167280e298 nuttcp.8"