aboutsummaryrefslogtreecommitdiffstats
path: root/community/obconf-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/obconf-qt/APKBUILD')
-rw-r--r--community/obconf-qt/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/obconf-qt/APKBUILD b/community/obconf-qt/APKBUILD
new file mode 100644
index 00000000000..4d131879b92
--- /dev/null
+++ b/community/obconf-qt/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=obconf-qt
+pkgver=0.16.4
+pkgrel=0
+pkgdesc="Qt port of obconf, the Openbox configuration tool"
+url="https://github.com/lxqt/obconf-qt"
+# s390x, riscv64: blocked by openbox
+# *: blocked by lxqt
+arch="all !s390x !armhf !riscv64"
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake samurai lxqt-build-tools liblxqt-dev
+ qt5-qttools-dev openbox-dev
+ "
+options="!check" # No testsuite
+subpackages="$pkgname-lang"
+source="https://github.com/lxqt/obconf-qt/releases/download/$pkgver/obconf-qt-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+lang() {
+ install_if="lang $pkgname=$pkgver-r$pkgrel"
+ amove usr/share/$pkgname/translations
+}
+
+sha512sums="
+4f75a5275e14cd7e8f0abc1bfcd40b4d860d613bc37c06c0e68d6f622ed126dce2fea98b5dd8e629b5de472ab5e668a5b0af7f6621d09fcb0b2287a11b0fb662 obconf-qt-0.16.4.tar.xz
+"