aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml-camlp4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ocaml-camlp4/APKBUILD')
-rw-r--r--community/ocaml-camlp4/APKBUILD58
1 files changed, 37 insertions, 21 deletions
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index aa61e3353f0..1b913532d38 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Jon Ong <jonongjs@rottenmage.com>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Contributor: Anil Madhavapeddy <anil@recoil.org>
-# Maintainer:
+# Maintainer: omni <omni+alpine@hack.org>
pkgname=ocaml-camlp4
_pkgname=camlp4
# NOTE: camlp4 version must match ocaml version!
-pkgver=4.13.0
+pkgver=4.14.0
_pkgver="${pkgver%.*}+1"
_ocamlver=${pkgver%.*}
-pkgrel=0
+pkgrel=3
pkgdesc="Caml preprocessor and pretty-printer"
-url="https://github.com/ocaml/camlp4/releases"
-# mips64 and riscv64 blocked by ocaml
-arch="all !mips64 !riscv64"
-license="LGPL-2.0-or-later-WITH-linking-exception"
-depends="ocaml-runtime=~$_ocamlver ocaml-ocamlbuild"
+url="https://github.com/camlp4/camlp4"
+arch="all !riscv64 !loongarch64" # ocaml
+license="LGPL-2.0-or-later WITH OCaml-LGPL-linking-exception"
+depends="ocaml-runtime~$_ocamlver ocaml-ocamlbuild"
depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="ocaml=~$_ocamlver ocaml-compiler-libs=~$_ocamlver
- ocaml-findlib ocaml-ocamlbuild-dev ocamlbuild"
+makedepends="
+ ocaml~$_ocamlver
+ ocaml-compiler-libs~$_ocamlver
+ ocaml-findlib
+ ocamlbuild
+ "
replaces="camlp4" # for backward compatibility
provides="camlp4=$pkgver-r$pkgrel" # for backward compatibility
subpackages="$pkgname-dev"
-source="$pkgname-$_pkgver.tar.gz::https://github.com/ocaml/camlp4/archive/$_pkgver.tar.gz"
+source="$pkgname-$_pkgver.tar.gz::https://github.com/camlp4/camlp4/archive/$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
build() {
@@ -40,21 +43,34 @@ package() {
dev() {
default_dev
replaces="camlp4" # for backward compatibility
- local sitelib="usr/lib/ocaml/$_pkgname"
cd "$pkgdir"
mkdir -p "$subpkgdir"/usr
mv usr/bin "$subpkgdir"/usr/
+}
+
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
+
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
- local path
- find $sitelib/ -name '*.cmx' -o -name '*.cmxa' > find.tmp
- while IFS= read -r -d '' path; do
- mkdir -p "$subpkgdir"/${path%/*}
- mv "$path" "$subpkgdir"/${path%/*}/
- done < find.tmp
- rm find.tmp
- rmdir "$subpkgdir"/$sitelib 2>/dev/null || true
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
}
-sha512sums="44d1134b9e9a5ec2e070c0da98a04cab3a6229741591cb0ba30b9603cdde629b7578ad2c7e727c5b4fe9932af713284cc931c84c5a229b2db106d780c23f8c97 ocaml-camlp4-4.13+1.tar.gz"
+sha512sums="
+7838bcfc88edec73667669ea6562435b946e79f0b4a0e8117a83b403936337f08aaf8abe39d8f800483d77381ae122fc89aa68505cf60ec2f1cc835a04da93f2 ocaml-camlp4-4.14+1.tar.gz
+"