aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ocaml/APKBUILD')
-rw-r--r--community/ocaml/APKBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 6a0ed49f660..665a4d0de6b 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml
-pkgver=4.08.1
+pkgver=4.09.0
pkgrel=0
pkgdesc="Main implementation of the Caml programming language"
url="http://ocaml.org/"
@@ -18,16 +18,14 @@ subpackages="
$pkgname-compiler-libs:_compiler_libs
$pkgname-runtime
"
-source="http://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/$pkgname-$pkgver.tar.gz
+source="http://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/ocaml-$pkgver.tar.gz
compile-without-debug-info.patch
- fix-mcontext-fields.patch
+ fix-mcontext-fields.patch
fix-segfault-in-ppc64le.patch
fix-check-parser-uptodate-or-warn.sh.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--prefix /usr \
--bindir /usr/bin \
@@ -35,20 +33,16 @@ build() {
--mandir /usr/share/man \
CC="${CC:-gcc}" \
AS="${CC:-gcc} -c" \
- ASPP="${CC:-gcc} -c"
+ ASPP="${CC:-gcc} -c"
make world.opt
}
check() {
- cd "$builddir"
-
# FIXME: there seem to be some spurious failures, ignore until fixed.
make -C testsuite all || true
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
@@ -102,8 +96,6 @@ runtime() {
'*.cma' \
'VERSION' \
'stublibs' \
- 'vmthreads/*.cmi' \
- 'vmthreads/*.cma' \
'threads/*.cmi' \
'threads/*.cma'
do
@@ -118,8 +110,8 @@ _submv() {
rmdir -p "$pkgdir"/${path%/*} 2>/dev/null || true
}
-sha512sums="8239c1879926e59c3d9611ad0d97618ce21b0528f1bd59db3df9c24287ad180ffa74f34e52e1fab39e71cbf8113a9a4ee5037cc33ae64ca6a9a109fe4ada0256 ocaml-4.08.1.tar.gz
-49cbd6df3a70d00df33d34ab4508dd04d52cbc94efc6c8cac8668758e7346be3c7acedf5b8af38a0adb18c69b8d0859667b12cc11699002c048af962cf283ad2 compile-without-debug-info.patch
+sha512sums="c1b666839960c157868fc32a96fe4137280a4b99464ba2c6616700b962d802ed86467ec21c341abbefdf684b8314b90fd6a5018c6de58dc29152af851eebea88 ocaml-4.09.0.tar.gz
+9421514297ae014c012f909f9b3fc08dbcac567aae9eaf2c404ed3be28c60b5cfbb55f7486185feaeb15df4f027c8754a121ee18487bc7943ec1c40b314c2e31 compile-without-debug-info.patch
cd0b9a8c3dc8d952a40eb1758cc74dc388ec4bcc5fe5a25c3f073f0088bf51027b53ea1b9f6d02a84b11bd3964bec1c50b5da28caa7c1e31ec76f9930ea7d527 fix-mcontext-fields.patch
e65b647427d9c94933d5be97857daf8cdc65e25c10066740dbcbab7a4e6f8ddb2277ee7d5796abf5916e5bdd59b057de736190432c480fc8ff2a4b2a94d46eca fix-segfault-in-ppc64le.patch
b3362906c23ecdb084db7dbf18cae22f0a54ba968f1ecf9c8d13c230ca221b3f77fa820a52e091ce7b71b1cb4a91faf1346692aa6fa411bb46fca784500def25 fix-check-parser-uptodate-or-warn.sh.patch"