aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml
diff options
context:
space:
mode:
Diffstat (limited to 'community/ocaml')
-rw-r--r--community/ocaml/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index ba038bcb862..e17f8b7e746 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -46,10 +46,13 @@ package() {
LIBDIR="$pkgdir"/usr/lib/ocaml \
MANDIR="$pkgdir"/usr/share/man
+ # Remove annotation files and sources.
+ find "$pkgdir"/usr/lib/ocaml \
+ \( -name '*.cmt' -o -name '*.cmti' -o -name '*.ml' \) \
+ -a -delete
+
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
-
- find "$pkgdir"/usr/lib/ocaml -name \*.ml -delete
}
sha512sums="42560874ce363212fa4e862138d7260113bc8dff8b39c040332bbd9b039ba938788344ba8ce63ffc0a251bf21a6e493f3c1e505b6f51db6fec4d21578921060e ocaml-4.06.1.tar.gz