aboutsummaryrefslogtreecommitdiffstats
path: root/community/okteta/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/okteta/APKBUILD')
-rw-r--r--community/okteta/APKBUILD52
1 files changed, 29 insertions, 23 deletions
diff --git a/community/okteta/APKBUILD b/community/okteta/APKBUILD
index f19df2f2e46..a000ce32471 100644
--- a/community/okteta/APKBUILD
+++ b/community/okteta/APKBUILD
@@ -1,46 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=okteta
-pkgver=0.26.6
+pkgver=0.26.15
pkgrel=0
pkgdesc="KDE hex editor for viewing and editing the raw data of files"
# armhf blocked by extra-cmake-modules
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.okteta"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND (GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- kbookmarks-dev
- kcmutils-dev
- kcodecs-dev
- kcompletion-dev
- kconfigwidgets-dev
- kcrash-dev
- kdbusaddons-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kio-dev
- knewstuff-dev
- kparts-dev
- kservice-dev
- kwidgetsaddons-dev
- kxmlgui-dev
+ kbookmarks5-dev
+ kcmutils5-dev
+ kcodecs5-dev
+ kcompletion5-dev
+ kconfigwidgets5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kio5-dev
+ knewstuff5-dev
+ kparts5-dev
+ kservice5-dev
+ kwidgetsaddons5-dev
+ kxmlgui5-dev
qca-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtscript-dev
qt5-qttools-dev
qt5-qtxmlpatterns-dev
+ samurai
shared-mime-info
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/utilities/okteta.git"
source="https://download.kde.org/stable/okteta/$pkgver/src/okteta-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_DESKTOPPROGRAM=ON
@@ -48,12 +53,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest -j1 --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="f489ddf1be6fe369b564b11cf8234c7a291b63101a00fb43163a1019609d1152735750946b2bd876080eff1697903ba02ada1ea641293a59f31d5edf34604b1a okteta-0.26.6.tar.xz"
+sha512sums="
+8e63b20ad3e1d238a6006fca834b355825015088a3dff82866e1197c2802e4a3cc57644d50b44407203bea2c2d4a132c89d402e52e4525d257de9a8cde87f1db okteta-0.26.15.tar.xz
+"