aboutsummaryrefslogtreecommitdiffstats
path: root/community/okular/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/okular/APKBUILD')
-rw-r--r--community/okular/APKBUILD58
1 files changed, 34 insertions, 24 deletions
diff --git a/community/okular/APKBUILD b/community/okular/APKBUILD
index d75c5934036..25b4496e57b 100644
--- a/community/okular/APKBUILD
+++ b/community/okular/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=okular
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-# ppc64le blocked by qt5-qtwebengine -> purpose
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
-url="https://kde.org/applications/office/org.kde.okular"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> purpose
+arch="all !armhf !ppc64le !s390x !riscv64"
+url="https://okular.kde.org/"
pkgdesc="A universal document viewer"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends="$pkgname-common"
@@ -16,7 +18,6 @@ makedepends="
djvulibre-dev
ebook-tools-dev
extra-cmake-modules
- kactivities-dev
karchive-dev
kbookmarks-dev
kcompletion-dev
@@ -28,8 +29,7 @@ makedepends="
kdoctools-dev
kiconthemes-dev
kio-dev
- kirigami2-dev
- kjs-dev
+ kirigami-dev
kparts-dev
kpty-dev
kwallet-dev
@@ -37,15 +37,19 @@ makedepends="
libkexiv2-dev
libspectre-dev
phonon-dev
+ plasma-activities-dev
poppler-qt5-dev
purpose-dev
qca-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
+ qt6-qtsvg-dev
+ samurai
threadweaver-dev
zlib-dev
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/graphics/okular.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/okular-$pkgver.tar.xz"
subpackages="
$pkgname-common
@@ -57,19 +61,20 @@ subpackages="
"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DOKULAR_UI=both
+ -DOKULAR_UI=both \
+ -DFORCE_NOT_REQUIRED_DEPENDENCIES="CHM;KExiv2Qt6"
+ # TODO: remove KExiv2Qt6 from not required dependencies
cmake --build build
}
check() {
- cd build
-
# All other tests are broken, require OpenGL, etc
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -R "^shelltest"
+ xvfb-run ctest --test-dir build --output-on-failure -R "^shelltest"
}
package() {
@@ -78,11 +83,11 @@ package() {
common() {
pkgdesc="Common files for okular and okular-mobile"
- amove usr/lib/qt5/plugins
- find "$pkgdir"/usr -name "libOkular5Core.so.*" -exec mv {} "$subpkgdir"/usr/lib/ +
+ amove usr/lib/qt6/plugins
+ find "$pkgdir"/usr -name "libOkular6Core.so.*" -exec mv {} "$subpkgdir"/usr/lib/ +
amove usr/share/okular
amove usr/share/config.kcfg
- amove usr/share/qlogging-categories5
+ amove usr/share/qlogging-categories6
amove usr/share/icons
amove usr/share/metainfo
amove usr/share/kconf_update
@@ -90,13 +95,18 @@ common() {
common_qml() {
pkgdesc="Common qml files for okular-mobile and other packages"
- depends="kirigami2"
+ depends="kirigami"
- amove usr/lib/qt5/qml
+ amove usr/lib/qt6/qml
}
mobile() {
- depends="$pkgname-common $pkgname-common-qml kirigami2"
+ depends="
+ $pkgname-common
+ $pkgname-common-qml
+ kirigami-addons
+ kitemmodels
+ "
amove usr/bin/okularkirigami
amove usr/share/applications/org.kde.okular.kirigami.desktop
@@ -104,5 +114,5 @@ mobile() {
}
sha512sums="
-21f34dcef50d15a8816d3898a002133e068ba239d1730892e0d71e58e6196b493544792fa5c06de689fdf1fe7f853586578f3963a64e46a9797484f983814c22 okular-21.04.3.tar.xz
+ae3991bec75ff9cb1648293a862bda1733bad6667b20e28d5055c5554a1387ea3b901d94b9f8a5cf363e173ff44f1469f36e2bb53cfd5ab18eb6fdb60e7cd644 okular-24.02.1.tar.xz
"