aboutsummaryrefslogtreecommitdiffstats
path: root/community/olm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/olm/APKBUILD')
-rw-r--r--community/olm/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/olm/APKBUILD b/community/olm/APKBUILD
index 60edd231b3f..abb78621ccd 100644
--- a/community/olm/APKBUILD
+++ b/community/olm/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=olm
-pkgver=3.2.11
-pkgrel=0
+pkgver=3.2.16
+pkgrel=1
pkgdesc="Implementation of the olm and megolm cryptographic ratchets"
arch="all"
url="https://gitlab.matrix.org/matrix-org/olm"
@@ -22,7 +22,7 @@ checkdepends="
py3-aspectlib
"
source="https://gitlab.matrix.org/matrix-org/olm/-/archive/$pkgver/olm-$pkgver.tar.gz"
-subpackages="$pkgname-dev py3-olm:py3"
+subpackages="$pkgname-dev py3-olm-pyc py3-olm:py3"
build() {
cmake -B build -G Ninja \
@@ -30,14 +30,13 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
-# make -C python
+
cd python
python3 setup.py build
}
check() {
- cd build/tests
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build/tests --output-on-failure
cd "$builddir"/python
local _pyarch
@@ -56,12 +55,18 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" make -C "$builddir"/python install-python3
}
py3() {
- depends="python3 py3-future py3-cffi"
- DESTDIR="$subpkgdir" make -C "$builddir"/python install-python3
+ depends="
+ py3-cffi
+ py3-future
+ python3
+ "
+ amove usr/lib/python3*
}
+
sha512sums="
-dfb44880ee3fc510d9a599a8571feec2395e9048036556b4591448096fc031534151c677aea4106f712a37e886b565de6109db96ed6c8bd302a3ee7caf88ae50 olm-3.2.11.tar.gz
+a75dbaa4321baf53dab820599ddb8740e5982a4537dd2f1df2de2d7bb5c9500d0d1af25f08495e37cc50d3176646d8d6f78bb24bc827f3c246242f07db90eea8 olm-3.2.16.tar.gz
"