aboutsummaryrefslogtreecommitdiffstats
path: root/community/olm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/olm/APKBUILD')
-rw-r--r--community/olm/APKBUILD51
1 files changed, 23 insertions, 28 deletions
diff --git a/community/olm/APKBUILD b/community/olm/APKBUILD
index fe73700f8e6..abb78621ccd 100644
--- a/community/olm/APKBUILD
+++ b/community/olm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=olm
-pkgver=3.2.4
+pkgver=3.2.16
pkgrel=1
pkgdesc="Implementation of the olm and megolm cryptographic ratchets"
arch="all"
@@ -9,48 +9,39 @@ url="https://gitlab.matrix.org/matrix-org/olm"
license="Apache-2.0"
makedepends="
cmake
- python3-dev
py3-cffi
py3-setuptools
+ python3-dev
+ samurai
"
checkdepends="
py3-pytest
+ py3-pytest-benchmark
py3-pytest-cov
py3-future
py3-aspectlib
"
-source="https://gitlab.matrix.org/matrix-org/olm/-/archive/$pkgver/olm-$pkgver.tar.gz
- 0001-only-export-olm-functions-to-avoid-colliding-with-ot.patch
- 0002-bypass-concatenation-issue-during-build.patch
-"
-subpackages="$pkgname-dev py3-olm:py3"
-
-case "$CARCH" in
- mips*)
- _disable_tests="
- --deselect tests/group_session_test.py::TestClass::test_encrypt \
- --deselect tests/group_session_test.py::TestClass::test_decrypt"
- ;;
- *) checkdepends="$checkdepends py3-pytest-benchmark" ;;
-esac
+source="https://gitlab.matrix.org/matrix-org/olm/-/archive/$pkgver/olm-$pkgver.tar.gz"
+subpackages="$pkgname-dev py3-olm-pyc py3-olm:py3"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
- make -C python olm-python3
+
+ cd python
+ python3 setup.py build
}
check() {
- cd build/tests
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build/tests --output-on-failure
cd "$builddir"/python
local _pyarch
case "$CARCH" in
- x86_64|aarch64|ppc64le|mips*) _pyarch="$CARCH" ;;
+ x86_64|aarch64|ppc64le) _pyarch="$CARCH" ;;
x86) _pyarch=i686 ;;
armhf|armv7) _pyarch=armv8l ;;
s390x) _pyarch=s390x;;
@@ -59,19 +50,23 @@ check() {
local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
# TODO: fails to find _libolm.abi3.so
- #PYTHONPATH="$PWD/build/lib.linux-$_pyarch-$_py3ver" pytest
+ # PYTHONPATH="$PWD/build/lib.linux-$_pyarch-$_py3ver" pytest
}
package() {
DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" make -C "$builddir"/python install-python3
}
py3() {
- depends="python3 py3-future py3-cffi"
- DESTDIR="$subpkgdir" make -C "$builddir"/python install-python3
+ depends="
+ py3-cffi
+ py3-future
+ python3
+ "
+ amove usr/lib/python3*
}
+
sha512sums="
-19fa85da108a16b938fc77033b9f0b05a58ca85183891b5b9d56ae5c963bcd90fb91fee58ab9d689131bef399538f4b0a786d7f0c1b81ceca46ddd9761bf0340 olm-3.2.4.tar.gz
-16c6a1f466dbd1f06103f6259fb8ad45e76716fe07920324a580d7d8d1d012b29c21b2370215dd166a1d802abee5ae03854325c2d5025b9a42180bd35595109b 0001-only-export-olm-functions-to-avoid-colliding-with-ot.patch
-9ae094f453e5e07f151f3ffc9be247a7b5d9704738f3a53bbd637b1f8c8458dee2e91397c17b8cfc9ceb2051a46acc77c937671c4a0a2eee52d73d6d6a767f3a 0002-bypass-concatenation-issue-during-build.patch
+a75dbaa4321baf53dab820599ddb8740e5982a4537dd2f1df2de2d7bb5c9500d0d1af25f08495e37cc50d3176646d8d6f78bb24bc827f3c246242f07db90eea8 olm-3.2.16.tar.gz
"