aboutsummaryrefslogtreecommitdiffstats
path: root/community/omxplayer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/omxplayer/APKBUILD')
-rw-r--r--community/omxplayer/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/community/omxplayer/APKBUILD b/community/omxplayer/APKBUILD
index 694d75f543c..12bd02f6dd0 100644
--- a/community/omxplayer/APKBUILD
+++ b/community/omxplayer/APKBUILD
@@ -2,12 +2,12 @@
pkgname=omxplayer
pkgver=0.20190102
_commitid=f06235cc9690a6d58187514452df8cf8fcdaacec
-pkgrel=5
+pkgrel=11
pkgdesc="Commandline OMX player for Raspberry Pi"
url="https://github.com/popcornmix/omxplayer"
arch="armhf armv7"
license="GPL-2.0"
-depends="ttf-freefont"
+depends="font-freefont"
makedepends="linux-headers raspberrypi-dev>=0.20181212 ffmpeg4-dev pcre-dev
boost-dev freetype-dev dbus-dev alsa-lib-dev"
options="!check"
@@ -25,13 +25,13 @@ source="omxplayer-$pkgver.tar.gz::https://github.com/popcornmix/omxplayer/archiv
builddir="$srcdir"/$pkgname-$_commitid
build() {
- cat <<EOF > Makefile.include
-INCLUDES:=-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux
-INCLUDES+=$(pkg-config --cflags freetype2 dbus-1)
-LDFLAGS:=-L/opt/vc/lib -Wl,-rpath,/opt/vc/lib
-LIBS:=$(pkg-config --libs freetype2 dbus-1)
-STRIP:=echo
-EOF
+ cat <<-EOF > Makefile.include
+ INCLUDES:=-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux
+ INCLUDES+=$(pkg-config --cflags freetype2 dbus-1)
+ LDFLAGS:=-L/opt/vc/lib -Wl,-rpath,/opt/vc/lib
+ LIBS:=$(pkg-config --libs freetype2 dbus-1)
+ STRIP:=echo
+ EOF
make omxplayer.bin
}
@@ -41,10 +41,10 @@ package() {
cp COPYING $pkgdir/usr/share/doc/omxplayer
cp README.md $pkgdir/usr/share/doc/omxplayer/README
- install -m755 -D "$srcdir"/$pkgname.initd \
- "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd \
- "$pkgdir"/etc/conf.d/$pkgname
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname
}
sha512sums="
@@ -53,6 +53,6 @@ c349eea5f7c513a07d82a6cf6467c4d21bcb29c053bc5e39d8f675b1212db9beef0abf5248d50ac5
2a8a6def1e09f726cba58c0b9109fa6c4fbd4a3b4f1d27d200488f262a0e0978579d83db7fe24f1d3e03beef318c3674ed79cbd2f1994c4551a59c9fe0f63489 issue-297.patch
3493d9600fda75a7599fada332c48e8790dcc46ada65b862bb14dafb701dd7ed89f3debf439160917b73d779f549898146b394e13c45dc7d77122a11a2ede97e fix-makefile.patch
8aa58aaa07453186302dc68d92f28c1b50bf0f8fccd50359640a7fc8339b233b32a0c8c02284a9974599e56d69cc557acc25e76e6438c6d64d15afd9c1788a8e default-font.patch
-3ddd32235d87a46478d0237ee9b253edeb75729e377b09a33069ecdca2ee230d2851f308897ee75ff69a9f3bdd2876f490bc1667a572dce1c186f80fddcf6df3 omxplayer.initd
+a6ce3f69960d8f6234438dcf981f54bdeef32f14aeb5ce7c8cb889806a2e8938512423e915f63e5a27206383b5f4741898622dfb36b88411c6b20a44036bd63a omxplayer.initd
4f906ada035869a0e515e7615056b18b0f6906ce4b3a2d34081c0efa79bb9455380f729e7c5270180f5ace89c53a7ac7c93f609e6761825f639f44aa22346bb2 omxplayer.confd
"