aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/opam/APKBUILD')
-rw-r--r--community/opam/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index a9e1d90e251..cee55b1b748 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -4,18 +4,21 @@
# Contributor: omni <omni+alpine@hack.org>
# Maintainer: Kate <kit.ty.kate@disroot.org>
pkgname=opam
-pkgver=2.1.2
+pkgver=2.1.5
pkgrel=2
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
-arch="all !riscv64" # ocaml
+arch="all !riscv64 !loongarch64" # ocaml
license="LGPL-2.1-only WITH OCaml-LGPL-linking-exception"
depends="curl patch unzip coreutils bubblewrap"
-options="net !check" # The tests use bubblewrap which cannot be run inside docker
-makedepends="curl tar ocaml-compiler-libs"
+options="!check" # The tests use bubblewrap which cannot be run inside docker
+makedepends="dune tar ocaml-compiler-libs"
checkdepends="rsync bash diffutils"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/opam/archive/$pkgver.tar.gz"
+source="https://github.com/ocaml/opam/releases/download/$pkgver/opam-full-$pkgver.tar.gz
+ makefile.patch
+ "
subpackages="$pkgname-doc"
+builddir="$srcdir/opam-full-$pkgver"
build() {
./configure \
@@ -28,8 +31,7 @@ build() {
--localstatedir=/var \
--with-mccs
- make -j1 lib-ext
- make -j1 all
+ make -j1 DUNE=/usr/bin/dune lib-ext all
}
check() {
@@ -42,5 +44,6 @@ package() {
}
sha512sums="
-bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396 opam-2.1.2.tar.gz
+e4e33fcee0a9f922f8b43c6b095554a946559a2c50341326d21cca0f24fc7105c0de01db204b408240b12b267c9929435e2c511adf140618c91873f10444ae90 opam-full-2.1.5.tar.gz
+0e9b1ccac3dc6b9f215a01ac9c30ca95a254240752af7ab9c6368b525e108b4b55cc460ca7ba8fcccca33103247a90f12779649d2823643f1e856cb3a8de50f0 makefile.patch
"