aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/opam/APKBUILD')
-rw-r--r--community/opam/APKBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 865fff94ccd..cee55b1b748 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -1,20 +1,24 @@
# Contributor: Michael Zuo <muh.muhten@gmail.com>
# Contributor: Sora Morimoto <sora@morimoto.io>
# Contributor: Anil Madhavapeddy <anil@recoil.org>
-# Maintainer: omni <omni+alpine@hack.org>
+# Contributor: omni <omni+alpine@hack.org>
+# Maintainer: Kate <kit.ty.kate@disroot.org>
pkgname=opam
-pkgver=2.0.8
-pkgrel=1
+pkgver=2.1.5
+pkgrel=2
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
-# mips64 and riscv64 blocked by ocaml -> ocaml-compiler-libs
-arch="all !mips64 !riscv64"
-license="LGPL-2.1"
-depends="curl patch unzip"
-makedepends="tar ocaml-compiler-libs"
-checkdepends="rsync"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/opam/archive/$pkgver.tar.gz"
+arch="all !riscv64 !loongarch64" # ocaml
+license="LGPL-2.1-only WITH OCaml-LGPL-linking-exception"
+depends="curl patch unzip coreutils bubblewrap"
+options="!check" # The tests use bubblewrap which cannot be run inside docker
+makedepends="dune tar ocaml-compiler-libs"
+checkdepends="rsync bash diffutils"
+source="https://github.com/ocaml/opam/releases/download/$pkgver/opam-full-$pkgver.tar.gz
+ makefile.patch
+ "
subpackages="$pkgname-doc"
+builddir="$srcdir/opam-full-$pkgver"
build() {
./configure \
@@ -24,10 +28,10 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var
+ --localstatedir=/var \
+ --with-mccs
- make -j1 lib-ext
- make -j1 all
+ make -j1 DUNE=/usr/bin/dune lib-ext all
}
check() {
@@ -39,4 +43,7 @@ package() {
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="14737dc994be2c54dfeaf2658d3713178033e1bc2b4b845a58b4bfc118bbbf12b502924add0ae32b4b2b6c1944462e5ee7143df3de362d9ee39573249d013bc9 opam-2.0.8.tar.gz"
+sha512sums="
+e4e33fcee0a9f922f8b43c6b095554a946559a2c50341326d21cca0f24fc7105c0de01db204b408240b12b267c9929435e2c511adf140618c91873f10444ae90 opam-full-2.1.5.tar.gz
+0e9b1ccac3dc6b9f215a01ac9c30ca95a254240752af7ab9c6368b525e108b4b55cc460ca7ba8fcccca33103247a90f12779649d2823643f1e856cb3a8de50f0 makefile.patch
+"