aboutsummaryrefslogtreecommitdiffstats
path: root/community/openblas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/openblas/APKBUILD')
-rw-r--r--community/openblas/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/openblas/APKBUILD b/community/openblas/APKBUILD
index d6c440060f4..13b36554c57 100644
--- a/community/openblas/APKBUILD
+++ b/community/openblas/APKBUILD
@@ -9,7 +9,6 @@ pkgdesc="A fast BSD-licensed BLAS based on gotoBLAS2, with LAPACK"
url="http://www.openblas.net"
arch="all"
license="BSD"
-depends=""
depends_dev="gfortran"
makedepends="$depends_dev perl linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
@@ -54,7 +53,7 @@ _flags64="$_flags
SYMBOLSUFFIX=64_"
prepare() {
- default_prepare || return 1
+ default_prepare
if [ "$CARCH" = "ppc64le" ] ; then
# Skip test level 3 on ppc64le for a while
@@ -66,31 +65,31 @@ prepare() {
build() {
CFLAGS= make -C "$builddir" \
- $_flags CFLAGS="$CFLAGS" PREFIX=/usr || return 1
+ $_flags CFLAGS="$CFLAGS" PREFIX=/usr
if $_ilp64; then
msg "Building with ILP64..."
CFLAGS= make -C "$_builddir64" \
- $_flags64 CFLAGS="$CFLAGS" PREFIX=/usr || return 1
+ $_flags64 CFLAGS="$CFLAGS" PREFIX=/usr
fi
}
package() {
if $_ilp64; then
make -C "$_builddir64" $_flags64 \
- PREFIX="$pkgdir/usr" install || return 1
+ PREFIX="$pkgdir/usr" install
fi
cd "$builddir"
- make $_flags PREFIX="$pkgdir/usr" install || return 1
+ make $_flags PREFIX="$pkgdir/usr" install
# Remove reference to $pkgdir.
sed -i "s|$pkgdir||" "$pkgdir"/usr/lib/cmake/$pkgname/OpenBLASConfig.cmake
mkdir -p "$pkgdir"/usr/share/doc/$pkgname
install -m 0644 Changelog.txt TargetList.txt USAGE.md \
- "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/
install -Dm 0644 LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE