aboutsummaryrefslogtreecommitdiffstats
path: root/community/openexr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/openexr/APKBUILD')
-rw-r--r--community/openexr/APKBUILD74
1 files changed, 58 insertions, 16 deletions
diff --git a/community/openexr/APKBUILD b/community/openexr/APKBUILD
index 23a80706dc0..32f862d167b 100644
--- a/community/openexr/APKBUILD
+++ b/community/openexr/APKBUILD
@@ -2,30 +2,37 @@
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Mark Riedesel <mark+alpine@klowner.com>
pkgname=openexr
-pkgver=3.1.2
+pkgver=3.1.13
pkgrel=0
-pkgdesc="A high dynamic-range image file format library"
+pkgdesc="High dynamic-range image file format library"
url="https://www.openexr.com/"
arch="all"
license="BSD-3-Clause"
makedepends="
boost-dev
- boost-python3
chrpath
cmake
+ imath-dev
+ samurai
zlib-dev
"
subpackages="
$pkgname-doc
$pkgname-tools
$pkgname-dev
+ $pkgname-libiex
+ $pkgname-libilmthread
+ $pkgname-libopenexr
+ $pkgname-libopenexrcore
+ $pkgname-libopenexrutil
"
source="$pkgname-$pkgver.tar.gz::https://github.com/openexr/openexr/archive/v$pkgver.tar.gz"
-# tests hopelessly broken on anything other than aarch64 and x86_64
-options="!check"
-
# secfixes:
+# 3.1.12-r0:
+# - CVE-2023-5841
+# 3.1.4-r0:
+# - CVE-2021-45942
# 3.1.1-r0:
# - CVE-2021-3598
# - CVE-2021-23169
@@ -64,28 +71,43 @@ options="!check"
# - CVE-2017-9115
# - CVE-2017-9116
+case "$CARCH" in
+ppc64le|s390x)
+ # fails a bunch of tests
+ options="$options !check"
+ ;;
+esac
+
build() {
- cmake -B build \
+ CFLAGS="$CFLAGS -O2 -flto=auto" \
+ CXXFLAGS="$CXXFLAGS -O2 -flto=auto" \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -DBUILD_TESTING="$(want_check && echo ON || echo OFF)" \
$CMAKE_CROSSOPTS
cmake --build build
}
check() {
- cd build
-
- _exclude_tests="OpenEXR.IlmImf"
+ local exclude_tests="(OpenEXR.testDeepScanLineBasic|OpenEXR.testCopyMultiPartFile|OpenEXRCore.testDWAACompression|OpenEXRCore.testDWABCompression"
case "$CARCH" in
- x86) _exclude_tests="($_exclude_tests|IlmBase.Imath)" ;;
- arm*) _exclude_tests="($_exclude_tests|OpenEXRCore.testHUF)" ;;
+ arm*)
+ exclude_tests="$exclude_tests|OpenEXR.testMultiTiledPartThreading|OpenEXR.testRgbaThreading|OpenEXR.testStandardAttributes|OpenEXR.testBackwardCompatibility"
+ ;;
+ x86)
+ exclude_tests="$exclude_tests|OpenEXR.testDwaLookups|OpenEXR.testOptimizedInterleavePatterns"
+ ;;
+ riscv64)
+ exclude_tests="$exclude_tests|OpenEXR.testMultiTiledPartThreading"
+ ;;
esac
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E $_exclude_tests
+ ctest --test-dir build --output-on-failure -j ${JOBS:-2} \
+ -E "$exclude_tests)"
}
package() {
@@ -96,6 +118,26 @@ tools() {
amove usr/bin
}
+libiex() {
+ amove usr/lib/libIex-*.so.*
+}
+
+libilmthread() {
+ amove usr/lib/libIlmThread-*.so.*
+}
+
+libopenexr() {
+ amove usr/lib/libOpenEXR-*.so.*
+}
+
+libopenexrcore() {
+ amove usr/lib/libOpenEXRCore-*.so.*
+}
+
+libopenexrutil() {
+ amove usr/lib/libOpenEXRUtil-*.so.*
+}
+
sha512sums="
-34fb28f149e49bb23b2dc230dd5277229f2c780de66aff0acc819601e6802a1dbf83110b5df455dffd63be6eaa286d4aedb4b0af559b8b034d98c3208ee9d969 openexr-3.1.2.tar.gz
+662ebfce32bc56e3b5140e7d1813b8c117ac6e806fe30c996b956465ce20ee43f1f535b97868a87a26d1d7909d7f59acbe383f335ab8d72ad1484408cbabf77b openexr-3.1.13.tar.gz
"