aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/openjdk7/APKBUILD')
-rw-r--r--community/openjdk7/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index b2fc312c69d..2e8e7ff714d 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -28,12 +28,13 @@ RHINO_VER=1.7.7.1
ANT_VER=1.9.7
case $CARCH in
-x86) _jarch=i386;;
-x86_64) _jarch=amd64;;
-arm*) _jarch=arm
- # openjdk has quite a bit of arm assembly producing textrels
- # and it's non trivial to fix. allow it for now.
- options="$options textrels";;
+x86) _jarch=i386;;
+x86_64) _jarch=amd64;;
+aarch64) _jarch=aarch64;;
+arm*) _jarch=arm
+ # openjdk has quite a bit of arm assembly producing textrels
+ # and it's non trivial to fix. allow it for now.
+ options="$options textrels";;
esac
INSTALL_BASE=/usr/lib/jvm/java-1.7-openjdk