aboutsummaryrefslogtreecommitdiffstats
path: root/community/openrct2/Werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/openrct2/Werror.patch')
-rw-r--r--community/openrct2/Werror.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/openrct2/Werror.patch b/community/openrct2/Werror.patch
new file mode 100644
index 00000000000..89d6dd65ec2
--- /dev/null
+++ b/community/openrct2/Werror.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 312ab67..74db2a7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -327,7 +327,7 @@ else ()
+
+ # Compiler flags
+ set(DEBUG_LEVEL 0 CACHE STRING "Select debug level for compilation. Use value in range 0–3.")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fstrict-aliasing -Werror -Wundef -Wmissing-declarations -Winit-self -Wall -Wextra -Wshadow")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fstrict-aliasing -Wundef -Wmissing-declarations -Winit-self -Wall -Wextra -Wshadow")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unknown-pragmas -Wno-missing-braces -Wno-comment -Wnonnull -Wno-unused-parameter -Wno-attributes")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DDEBUG=${DEBUG_LEVEL}")
+