aboutsummaryrefslogtreecommitdiffstats
path: root/community/opustags/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/opustags/APKBUILD')
-rw-r--r--community/opustags/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/opustags/APKBUILD b/community/opustags/APKBUILD
new file mode 100644
index 00000000000..792d62dc577
--- /dev/null
+++ b/community/opustags/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Alexey Yerin <yyp@disroot.org>
+# Maintainer: Alexey Yerin <yyp@disroot.org>
+pkgname=opustags
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="Ogg Opus tags editor"
+url="https://github.com/fmang/opustags"
+arch="all"
+license="BSD-3-Clause"
+makedepends="cmake libogg-dev samurai"
+subpackages="$pkgname-doc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/fmang/opustags/archive/refs/tags/$pkgver.tar.gz
+"
+options="!check" # Contains no tests
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=None \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+cd3ce0bb41c566e47acb0a4736deca5aa9c975b64afc13848dd29a48032bd1abc26fc3889006f1a18bece0c1b90f84f86170166fa3c9fd5d007073d15b4da20d opustags-1.9.0.tar.gz
+"