aboutsummaryrefslogtreecommitdiffstats
path: root/community/os-prober/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/os-prober/APKBUILD')
-rw-r--r--community/os-prober/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/os-prober/APKBUILD b/community/os-prober/APKBUILD
index b2b24959e63..b50463ec5fa 100644
--- a/community/os-prober/APKBUILD
+++ b/community/os-prober/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=os-prober
-pkgver=1.79
-pkgrel=0
+pkgver=1.81
+pkgrel=2
pkgdesc="Utility to detect other OSes on a set of drives"
url="https://joeyh.name/code/os-prober/"
-arch="all"
+arch="all !s390x" # grub-mount does not support s390x
+depends="grub-mount blkid"
license="GPL-3.0-only"
-source="http://http.debian.net/debian/pool/main/o/os-prober/os-prober_$pkgver.tar.xz"
+source="https://deb.debian.org/debian/pool/main/o/os-prober/os-prober_$pkgver.tar.xz"
options="!check" # No tests
-builddir="$srcdir/$pkgname"
build() {
make newns
@@ -21,8 +21,7 @@ package() {
install -Dm755 common.sh "$pkgdir"/usr/share/os-prober/common.sh
for dir in os-probes os-probes/mounted os-probes/init linux-boot-probes linux-boot-probes/mounted; do
- install -dm755 "$pkgdir"/usr/lib/"$dir"
- install -m755 -t "$pkgdir"/usr/lib/"$dir" "$dir"/common/*
+ install -Dm755 -t "$pkgdir"/usr/lib/"$dir" "$dir"/common/*
if [ -d "$dir"/x86 ]; then
cp -r "$dir"/x86/* "$pkgdir"/usr/lib/"$dir"
fi
@@ -33,5 +32,5 @@ package() {
}
sha512sums="
-89b827b9b90a1d3bc11e0090ec04d808502cc1883ab10997b6d9edbe6005dcf8a0acdd7d200102c9dccde56297bda6087d68fb6dec419f0920090c2655c9c7d8 os-prober_1.79.tar.xz
+ffb0e618f9e58a7a8e4a265d253bad4e168c220697216684acb38dbfa20680e552eb7c5f3d2186cd750c61a8929bf152527aa85c39318ed8b025a4ffffadde50 os-prober_1.81.tar.xz
"