aboutsummaryrefslogtreecommitdiffstats
path: root/community/oxygen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/oxygen/APKBUILD')
-rw-r--r--community/oxygen/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/oxygen/APKBUILD b/community/oxygen/APKBUILD
index 322a20d871a..a6b2bc24a2c 100644
--- a/community/oxygen/APKBUILD
+++ b/community/oxygen/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=oxygen
-pkgver=5.25.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="Artwork, styles and assets for the Oxygen visual style for the Plasma Desktop"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
makedepends="
@@ -22,7 +24,8 @@ makedepends="
kwayland-dev
kwidgetsaddons-dev
kwindowsystem-dev
- qt5-qtbase-dev
+ libplasma-dev
+ qt6-qtbase-dev
samurai
xcb-util-dev
"
@@ -31,11 +34,12 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/oxygen-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/oxygen.git"
+source="https://download.kde.org/stable/plasma/$pkgver/oxygen-$pkgver.tar.xz"
build() {
- cmake -B build -G Ninja \
+ cmake -B build -DBUILD_QT5=OFF -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -43,8 +47,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -52,5 +55,5 @@ package() {
}
sha512sums="
-a7dbd73034fe39260315debddfdbbc3e99a4519907372945f129604d4e8ae9d6643f10e53b1cd4af635609dfe774fdf809be492742b57864d636a6a08ea315db oxygen-5.25.2.tar.xz
+9cfc66e10c155aac24afaa02633768a5ed9b61aae79bcb40010d138e19b83b15d56fd330e21c7ff424da526ee7f5a5f0d2671491205da5de4f9c562fe33d06f9 oxygen-6.0.4.tar.xz
"