aboutsummaryrefslogtreecommitdiffstats
path: root/community/oxygen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/oxygen/APKBUILD')
-rw-r--r--community/oxygen/APKBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/community/oxygen/APKBUILD b/community/oxygen/APKBUILD
index 5d0f5ede8b1..a6b2bc24a2c 100644
--- a/community/oxygen/APKBUILD
+++ b/community/oxygen/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=oxygen
-pkgver=5.22.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="Artwork, styles and assets for the Oxygen visual style for the Plasma Desktop"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
makedepends="
@@ -22,7 +24,9 @@ makedepends="
kwayland-dev
kwidgetsaddons-dev
kwindowsystem-dev
- qt5-qtbase-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ samurai
xcb-util-dev
"
@@ -30,31 +34,26 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/oxygen-$pkgver.tar.xz"
-subpackages="$pkgname-lang $pkgname-sounds::noarch"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/oxygen.git"
+source="https://download.kde.org/stable/plasma/$pkgver/oxygen-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -DBUILD_QT5=OFF -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sounds() {
- pkgdesc="$pkgdesc (sounds)"
-
- amove usr/share/sounds
-}
sha512sums="
-5002d0260a5bf93ac98d9262330f4db8484c0a6ecbd217783321bf916ef4a8f27e5c94d301e6da95cf8f276ab210e14765439f8ff6be44220e8f526d7bb24fe1 oxygen-5.22.5.tar.xz
+9cfc66e10c155aac24afaa02633768a5ed9b61aae79bcb40010d138e19b83b15d56fd330e21c7ff424da526ee7f5a5f0d2671491205da5de4f9c562fe33d06f9 oxygen-6.0.4.tar.xz
"